Cannot create a project, build, or pio run from cli

Hey! Trying to reinstall platformIO on my new computer, and i’m having loads of trouble.
My goal is to write for a NodeMCU ESP8266 using Espressif8266 and the esp12e board
I’m using Win10 Build 19043, VS Code 1.62.2, PlatformIO IDE v2.4.0, and Python 64bit 3.9.5

On my first install, just installing the extension through VS Code, I couldn’t get a project to create in VS Code or through pio home on the command line. I uninstalled PIO (and deleted .platformio) and VS Code, and then reinstalled VS Code. After reinstalling VS Code, PIO wouldn’t install through VS Code at all, always hanging on the installing portable python step, so I installed PIO core through the python install script and then through VS Code and everything installed.

After getting it installed a second time, projects still will not create through VS Code, always hanging on the Project Wizard page (yes, i know you should wait, i’ve let it run for an hour+), however, if i run pio home through a windows command prompt and then create a project it will actually create no problem, and will appear in VS Code. However, even after creating a project in the browser, upon actually trying to build it in VS Code, I get the error command not found

I’ve also tried running pio update and pio upgrade, and both completed successfully. pio run however hangs displaying Processing esp12e (platform: espressif8266; board: esp12e; framework: arduino)

TL:DR: PIO for VS Code hangs on Project Wizard and won’t create projects, won’t build even if a project is created; running pio home from command line will let me build a project, but i can’t pio run or build from VS Code

I hope this is something super simple i’m missing, as PIO worked flawlessly from install on my old rig.
Thanks! not found - the command system does not know where to turn to.

Try to remove the PIO correctly through the VSCODE add-on manager. Delete all versions of PYTHON from the control panel (if any) then delete the .platformio folder in the user’s profile folder.

There is a nuance with the installation of python. Sometimes it is necessary to install it separately in accordance with the manual and the PATH parameter

Is this the version of Python that gets installed from Microsoft’s marketplace by any chance? If so, it is known for “not working” when used with PlatformIO and VSCode. I’m not sure if it works on the command line with PlatformO commands, but I suspect not.

If you have installed the marketplace version, please uninstall it and then install the proper Python install from

I believe also that version 3.9 had some (teething?) troubles and didn’t work with PlatformIO, I haven’t read anything that they have been fixed yet, but I might just have missed any announcements about it. I’m on Linux and using Python 3.8.10 with no problems, within VSCode and on the command line. You should be able to get hold of a 3.8 from if necessary.