Cannot connect to programmer

Hi all,

I am using FreeRTOS_AVR library and normally have no problems with uploading the firmware. Today i was doing some changes in the code I wanted to upload the new firmware to test it but with no success.
I am using an Arduino micro pro:
this is the output afer trying to upload.

Looking for upload port...
Auto-detected: COM12
Forcing reset using 1200bps open/close on port COM12
Waiting for the new upload port...
Uploading .pioenvs\sparkfun_promicro16\firmware.hex

Connecting to programmer: .

Found programmer: Id = "�"; type = 
Software Version = �.; Hardware Version = .
avrdude: error: buffered memory access not supported. Maybe it isn't
avrdude: initialization failed, rc=-1
avrdude: error: programmer did not respond to command: leave prog mode
avrdude: error: programmer did not respond to command: exit bootloader
a butterfly/AVR109 but a AVR910 device?
Double check connections and try again, or use -F to override
this check.

avrdude done.  Thank you.

*** [upload] Error 1
 [ERROR] Took 401.20 seconds

and this is my platformio.ini

platform = atmelavr
board = sparkfun_promicro16
framework = arduino
lib_deps =
 # Using a library name

I also tried to upload the sample firmware blink.ino with Arduino software and has no problem at all, so this is why am asking here.}

I hope you can help me.

I tried to upload the firmware from another computer and had no problems at all. Anyone can explaing to me why this is happening? Both operating systems are windwos 10.