"Cannot configure port" when uploading to ESP-01s

First time ever working with an embedded device.
I have the ESP-01s and trying to upload a simple blink program to it.

Here is the error I get:

Also did some changes to platformio.ini after looking at similar threads:
platform = espressif8266
board = esp01_1m
framework = arduino
build_flags = -D LED_BUILTIN=2
board_build.flash_mode = dout

I think the problem is the chip I use to flash the program.
I bought it from a local vendor with both the ESP-01s and a programmer USB included.
It’s not very detailed, but here is the store page:

At least you’ll get a look on the programmer USB, the one I have might be bad.

I read online some programmer USB’s need a driver. I don’t have any other driver installed on my PC other than whatever Platformio installs.

My code is written in C++, not sure if it is C only. I guess there would be explicit errors about this if it was the case. Here is the code:
#include <Arduino.h>

void setup() {

void loop() {
digitalWrite(LED_BUILTIN, HIGH);
digitalWrite(LED_BUILTIN, LOW);

Would greatly appreciate some guidance.

Tried esp8266 - PermissionError(13, 'A device attached to the system is not functioning.', None, 31)Serial port COM4 - Stack Overflow?

Interesting, that seems to help a bit. Still no successfull upload though, I’m getting:

A fatal error occurred: Failed to connect to ESP8266: Timed out waiting for packet header

At least I can see the serial port available when selecting project port.
The ESP is not blinking when I try to upload as others have described. I’m not sure if it is the right driver either as there is no chip name on the usb module. I guess we wouldn’t see the correct port if the driver didn’t work though.

Perhaps the usb module isn’t correctly setting the ESP to flash mode?

Try all available reset methods one by one.


I connected CH_PD to 3.3V (HIGH) and GPIOo to GND (LOW) as instructed here:

The upload completes now, but connecting the ESP to 3.3V( +??) and GND( -??) doesn’t do anything. The builtin led blinks once and that’s it.

I now have a feeling I might have connected things to each other that should have had a resistor between them, but no damage seems to be done. I’ll walk through your list.

EDIT: Tried not to connect the pins myself but test the reset methods to no avail.

Got it working.
Not sure exactly what did it, but here is the platformio.ini:
platform = espressif8266
board = esp01_1m
framework = arduino
upload_resetmethod = ck
build_flags = -D LED_BUILTIN=2
board_build.flash_mode = dout

I also manually connected CH_PD to VCC, and GPIO0 to GND. Seems like this is something the usb flasher didn’t do itself. Might solder those connections on the flasher together, setting everything up otherwise is a hassle. With these ini settings the ESP-01s should be reset correctly.