Cannot build, VSCode says to Configure a task

Using VSCode 1.56 with PlatformIO Core 5.1.1

When I click on the checkmark to build I get a message at the top to Configure a task. It lists several folders but none of them work when picked. I did see posts about removing an autodetect field in settings but I have no such item to delete.

Same observed in Clicking Build open a dropdown list, please check the suggestions there.

Thanks, but unfortunately none of these suggestions worked for me. This is really unfortunate for PlatformIO but maybe is just a natural consequence of the way VSCode is designed where extensions from other parties will render another extension almost completely useless.

I was a big fan of PlatformIO but when you launch the product and cannot even do a simple compile right out of the box, that user experience is unacceptable.

Also, searching through the forums shows that many have experienced this issue over the last year and there is no concise tech note for how to resolve. Not good.

OK this worked for me:

  • Open Visual Code
  • Open your project
  • Go to extensions
  • Uninstall PlatformIO
  • Reload Visual code as suggested by IDE
  • Install PlatformIO
  • Install the extra features as suggested by the IDE

Thanks that worked. Hooray!

I’ve also updated to


and I have not encountered that error ever since.

Correcion: No I still get the error but a quick VSCode restart always fixes it.