Cannot build LittleFS filesystem

Suddenly I cannot build my LittleFS filesystem. It worked this morning but now I get Error 3221225781. Building and uploading program works ok.

PS E:\C\Arduino\Elgrej_VSC> C:\Users\Peak\.platformio\penv\Scripts\platformio.exe 'run', '--target', 'buildfs', '--environment', 'myEnv' --verbose
Processing myEnv (board: d1_mini; platform: espressif8266; framework: arduino; monitor_speed: 115200; board_build.filesystem: littlefs; board_build.flash_mode: dout; monitor_rts: 0; monitor_dtr: 1)
------------------------------------------------------------------------------------------------------------------------
CONFIGURATION: https://docs.platformio.org/page/boards/espressif8266/d1_mini.html
PLATFORM: Espressif 8266 (4.0.1) > WeMos D1 R2 and mini
HARDWARE: ESP8266 80MHz, 80KB RAM, 4MB Flash
PACKAGES:
 - framework-arduinoespressif8266 @ 3.30002.0 (3.0.2)
 - tool-esptool @ 1.413.0 (4.13)
 - tool-esptoolpy @ 1.30000.201119 (3.0.0)
 - tool-mklittlefs @ 1.203.210628 (2.3)
 - tool-mkspiffs @ 1.200.0 (2.0)
 - toolchain-xtensa @ 2.100300.210717 (10.3.0)
LDF: Library Dependency Finder -> https://bit.ly/configure-pio-ldf
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 35 compatible libraries
Scanning dependencies...
Dependency Graph
|-- ESP8266WebServer @ 1.0 (License: Unknown, Path: C:\Users\Peak\.platformio\packages\framework-arduinoespressif8266\libraries\ESP8266WebServer)
|   |-- ESP8266WiFi @ 1.0 (License: Unknown, Path: C:\Users\Peak\.platformio\packages\framework-arduinoespressif8266\libraries\ESP8266WiFi)
|-- ESP8266WiFi @ 1.0 (License: Unknown, Path: C:\Users\Peak\.platformio\packages\framework-arduinoespressif8266\libraries\ESP8266WiFi)
|-- LittleFS @ 0.1.0 (License: Unknown, Path: C:\Users\Peak\.platformio\packages\framework-arduinoespressif8266\libraries\LittleFS)
Building in release mode
"mklittlefs" -c data -p 256 -b 8192 -s 1024000 .pio\build\myEnv\littlefs.bin
*** [.pio\build\myEnv\littlefs.bin] Error 3221225781
============================================== [FAILED] Took 1.97 seconds ==============================================

Any idea?

What files are in the data folder, can you upload that?

It’ s pure text files, .html, .css, .js which can be accessed successfully from the running program.
I tried with an empty data folder, same result.
I tried with another board, brand new, same result.
Since this is a build, not upload, I get the same result with the USB cable disconnected.

According to Goggle that’s a Windows error code for STATUS_DLL_NOT_FOUND. Let’s see if the program can still be executed.

Open a CLI and execute

pio pkg exec -p tool-mklittlefs -c "mklittlefs --version"

What’s the output?

Strange that I didn’t find any clear explanation of that error code although I googled a lot.
Output is:
Using tool-mklittlefs@1.203.210628 package

mklittlefs version: 0.2.3-35-g943d2f7

Okay that exactly matches mine. Now execute

pio pkg exec -p tool-mklittlefs -c "mklittlefs -c data -p 256 -b 8192 -s 1024000 test.bin"

Is a test.bin file of size ~1MB created?

(Assumes shell is opened in the projcet directory)

1 Like

Thank You! I had done some tests to try to download the filesystem image and had put mklittlefs.exe in the project directory. When removed, everything works again!