Can you provide me help supporting ESP32-DevKitM-1 v1.0?

Hi there!

I’m very new at IoT development and I randomly bought an ESP32-DevKitM-1 to start testing things.
It appears it is not officially supported by common IoT IDEs and tools (tested Arduino IDE and ESP-IDF).

With ESP-IDF, I succeeded in running my own program on this board, however I had to set the CONFIG_FREERTOS_UNICORE flag in menuconfig because the ESP32-MINI-1 on this board is monocore. ESP-IDF is far too complicated to use and I want to switch to this PlatformIO environment.

There are many ESP boards supported but I did not find my specific ESP32-DevKitM-1. I’m currently using “Espressif 32 Dev Module” but end up with that same issue with monocore.

I tried to put build_flags = -DCONFIG_FREERTOS_UNICORE=YES into my platform.ini file:

platform = espressif32
board = esp32dev
framework = arduino
monitor_speed = 115200

without any success.

Can you help me?

Same misunderstanding as in here.

Even more develish for PlatformIO: Depending on the manufacturing date, this board is dualcore, not unicore.

Thing is that this is an Arduino issue per

and by the second last comment they seem to still not want to have official Unicore support.

As stated in the above thread, you can try and use the modified tasmota platform which explicitly has unicore boards and modified frameworks to support it.

; includes 2.0.6 arduino-esp32
platform =
; automatically selects framework-arduino-solo1 unicore variant
board = esp32-solo1
framework = arduino

Thank you very much for your advice. It seems to work very well.

I’m just feeling uncomfortable using a platform that is not exactly designed for my device. I’m wondering if it is well optimized, regarding power consumption for instance.