Can' install PlatformIO into VSCode


I’m new for both softwares. I installed VScode easily. But I can’t install PlatformIO. Neither with the internal VScode installer nor with the .vsix file. Always the same error massage.

Error: Traceback (most recent call last): File “C:\Users\Familie Seidel.platformio.cache\tmp\”, line 69, in main() File “C:\Users\Familie Seidel.platformio.cache\tmp\”, line 61, in main bootstrap() File “C:\Users\Familie Seidel.platformio.cache\tmp\”, line 47, in bootstrap pioinstaller.main.main() File “C:\Users\Familie Seidel.platformio.cache\tmp.piocore-installer-8r74y8ps\tmpk7gd3oql\\”, line 122, in main File “C:\Users\Familie Seidel.platformio.cache\tmp.piocore-installer-8r74y8ps\tmpk7gd3oql\\click\”, li…

Any idea? I installed also the latest Phython version (3.9.0)

Thanks for your help. Answers also in German possible.


Some users have reported that there are errors when installing PlatformIO with a Windows username that has spaces in it. As in this topic: Problem to install platformio IDE on VScode - #8 by f5cwu

Can you create a new Windows user in the system settings panel that has no space in the name, and attempt installation there?

@ivankravets this might be an interesting bug

Space is OK for PlatformIO. I’ve even tried this in my virtual machine and it works well. I know that ESP-IDF does not like spaces.

Could you provide more detailed output?


it work with wifes user who is “Nicole”.
Thanks for the tip.

For completeness sake, can you log back into the first user account and attempt PlatformIO installation again? When the error shows up, please go into Help -> Toggle Developer Tools -> Console and find the error message, which you can then expand with the arrow to the left to it. That should reveal the full error message that helps to find the real cause.