PlatformIO Community

Build Marlin 2.0 faied due to the 'framework-arduino-lpc176x @ 0.1.3'

Hi, I am new here. I have a problem when using the PlatformIO IDE, hope could get some help here.

Here is the problem:
I am trying to use the VScode +PlatformIO to build the Marlin 2.0 firmware, but the build process always show me the error “Error: Could not find the package with ‘framework-arduino-lpc176x @ 0.1.3’ requirements for your system ‘windows_amd64’”
image

I downloaded the 0.1.3 framework-arduino-lpc176x package and put it under the .platformio\platforms path, restart the VScode, does not work.

Thanks for any help. :smiley:

Are you using the latest Marlin code base? There were changes that needed to be done regarding PIO core 5 which only allows package installation from the trusted PlatformIO repository.

Also see thread at Marlin: Help me ERRROR ModuleNotFoundError.

Thanks, man!! I tried the latest 2.0.6.1 once but failed so I give it up. After reading your post, I downloaded the 2.0.6.1 and it worked this time.

Thanks a lot!! :grinning: