BSEC Software Library latest version not available in registry

I’m trying to make use of the latest version of the BSEC Software Library released on GitHub as version 1.6.1480.

From reading posts here my understanding is that there is a daily crawler that should fetch details of new releases and update the library registry accordingly however that does not seem to have happened here. It has been a couple of days and the new version has still not been picked up.

Could someone take a look?

The crawler just seems to be slow, the new version was released 2 days ago and will be picked eventually (right @ivankravets?).

If you want to use the latest Github version before the crawler picks it up, just use the documented command

lib_deps =

(or with #v1.6.1480 at the end if you want to fix the tag)


@maxgerhardt Thanks; using the external git source does indeed work fine. The reason I was asking about the registry update though is that I have a custom component I’m looking to get into PR review for the esphome project which as standard makes use of the registry and I didn’t want to break with that norm. If the crawler is going to get to it eventually then that’s fine, I can wait; I just raised it as it seemed to be taking longer than advertised!

The library still was not updated. I think this because an erraneous file?
I made a PR:

Seems odd as it was like that for the last published version too? See comparison between versions.

I’d have expected the crawler to be respecting library.json though since it’s available?

If that PR works it would be weird to me. This updates the Arduino manifest ( – the crawler will use the library.json if available. And the original architectures declaration is valid in the Arduino manifest (source). Do you have a reference to when that made things work?

Sorry, it was an issue on our side. We’ve fixed it.


Thanks for taking a look and sorting it out :smiley:

1 Like