PlatformIO Community

BLE Nano V2 library issues


#1

Hey community,
today i got a RedBear BLE NANO v2 for my study project and i tried to get it running with PlatformIO.
But i had to witness, that i cant really get started with it because every Example Program i found to test the device didnt work because there are thousands of Library’s missing every Time.
I mean, the BLE Nano V2 is listed as an supported device on PlatformIO, but how can i get all the library’s working ?
For now i feel pretty dumb :confused:
I would be glad if you could help me :wink:
Greetings
Philipp


#2

Could you share what the exact library and example code was that you tried? Was the library specifically made for the Nordic nRF52 platform (with the NRF52832 chip)?


#3

Hey,
thanks for the quick answer :wink:
I tried to implement the simpleChat example from the mbed page, just to get the Bluetooth working and send some messages, because we want to use BLE to send and recieve data from sensors.
In PlatformIO i couldnt find any library for the BLE Nano at all. And there is literally no exapmle Code in the Internet which i can get running without getting told that for Example “mbed.h”, “ble/BLE.h” and such libraries are missing. I tried to export the libraries from the mbed online ide and implement them in PlatformIO but especially the mbed.h file keeps missing and i dont know where to find them.
I’d appreciate further help :slight_smile:
Thx in advance


#4

The documentation page for mbed lists a link to several example for the nRF52 platform, including arduino-ble-led which is BLE controlled LED, compilable for the redbear_blenano2 board. It uses the Arduino framework (not mbed!) and the BLEPeripheral.h header file from the BLEPeriphal library for BLE functions. Note that mbed does support the RedBear Nano 2 (here) but PIO apparently doesn’t have that target enabled yet.