Avrdude: jtagmkII_getsync(): sign-on command: status -1

I have configured plaformio.ini as per the docs and i still get:

platform = atmelmegaavr
board = AVR128DB48
framework = arduino
monitor_speed = 115200
board_build.mcu = avr128db48
board_build.f_cpu = 24000000L
avrdude: jtagmkII_getsync(): sign-on command: status -1

The com port is available and there are no other apps running / tied to it.

The error indicates that there is a problem with the board…

Any thoughts / guidance or help would be appreciated.


Does the chip have the Optiboot USB bootloader flashed on it? With which method / settings do you flash it in the Arduino IDE?


Here is the hardware kit:

Yes it has a bootloader, Arduino programmer:
Curiosity Namo (nEDBG, debug chip:ATSAMD21E18)


I think if it has a bootloader you 1. want to use upload_protocol = arduino so that it ends up calling avrdude -c arduino ... and 2. you might need the improvements from https://github.com/platformio/platform-atmelmegaavr/pull/48 since that informs the core it’s running with OPTIBOOT.

Let my try some things out…


I just checked (memory failing…)

There is NO optibootloader.


Okay. I also noticed we have

and it uses the upload protocol pkobn_updi.

Have you tried using board = curiosity_nano_db instead of



That did it: board = curiosity_nano_db.

Once again, thank you for the help!


1 Like