Avrdude: error: buffered memory access not supported - during Blink upload to Huzzah Feather

First time user trying to upload the Blink tutorial via PlatformIO IDE on Linux. A lot of things are already working but Upload is failing. The actual error is at the very bottom of this post. To clear up some questions here’s what’s already working:
Uploading via the Arduino programming environment works.
pio device monitor --port /dev/ttyUSB0 --baud 115200 - Works

One issue is that I can’t seem to set the baud rate for either Monitor or Upload. platformio.ini looks like this:
platform = atmelavr
board = feather32u4
framework = arduino
upload_speed = 115200 — changing upload speed has no effect
upload_port = /dev/ttyUSB0 — changing the port propagates through to the upload log
monitor_speed = 9600 — changing monitor speed has no effect

Below is the upload log with some redundant lines removed.

Building .pioenvs/feather32u4/firmware.hex
Checking size .pioenvs/feather32u4/firmware.elf
Configuring upload protocol…
Use manually specified: /dev/ttyUSB0
Forcing reset using 1200bps open/close on port /dev/ttyUSB0
Waiting for the new upload port…
Uploading .pioenvs/feather32u4/firmware.hex

Found programmer: Id = “hello f”; type = o
a butterfly/AVR109 but a AVR910 device?

*** [upload] Error 1
avrdude: error: buffered memory access not supported. Maybe it isn’t (line is truncated in log)
avrdude: initialization failed, rc=-1

Please file an issue here Issues · platformio/platform-atmelavr · GitHub

Problem solved. There are a few different Adafruit Feather boards with configurations that need to be translated into pio-eze. In my case the Adafruit Huzzah Feather requires the following lines in platformio.ini
platform = espressif8266
board = huzzah

Once I had the right .ini settings everything just worked.

General question: Is there a handy table somewhere that maps boards to platform settings?