Autocomplete stopped working

Even using the blink example provided I can not get autocomplete, running the latest version. Any idea? Used to work before.


Have tried rebuild C/C++ project, my linter is working correctly, just not autocomplete.

Please switch to PlatformIO IDE for VSCode. See difference here A professional collaborative platform for embedded development · PlatformIO

Ah thanks, that indirectly led me to the solution! It was xcode that was updated and needed it’s license to be agreed on before allowing clang to work again…

Checking out VSCode, really nice, very fast. What linter to use with platformio?

Could you try to create settings.json file in project’s .vscode folder with the next contents:

    "C_Cpp.intelliSenseEngine": "Default"

Does it work?

1 Like

That does enable it yeah! Thanks, although it’s not working as you type, only on save.