PlatformIO Community

Autocomplete not working Atom (ubuntu)


#1

Hi,

I have installed PlatformIO, but autocomplete not working properly, I try to put “digitalRead” but nothing appear, only words already in the existing file.


#2

Did you install Clang?

In any case, we highly recommend to try VSCode http://platformio.org/platformio-ide


#3

Yes, I already have Clang. The problem is with the package “Autocomple-clang”.

The console show an error when the package is try to running (108 warnings, 28 errors). and “too many errors”.

I have VSCode, but, I don’t like that I only have one active project, is very annoying when I try to switch between projects.

I use Ubuntu 16.04 x64


#4

We have a feature request for that https://github.com/platformio/platformio-vscode-ide/issues/50

Could you share your platformio.ini?


#5

; PlatformIO Project Configuration File
;
; Build options: build flags, source filter
; Upload options: custom upload port, speed and extra flags
; Library options: dependencies, extra library storages
; Advanced options: extra scripting
;
; Please visit documentation for the other options and examples
; http://docs.platformio.org/page/projectconf.html

[env:uno]
platform = atmelavr
board = uno
framework = arduino


#6

Please open PIO IDE Terminal and type clang --version. Which version do you use?


#7

$USER:~/Dropbox/Proyectos$ clang --version
clang version 3.8.0-2ubuntu4 (tags/RELEASE_380/final)
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/bin


#8

Do you see any errors in Atom > Menu > View > Developer > Toggle Developer Tools > Console ?


#9

yes,

108 warnings and 28 error, then say, “too many error”, and the package is stoped


#10

Now, I have the same problem with atom on windows 10.


#11

Ok, was only out of update, its ok…