ATtiny sketch upload fails (stk500_recv()) but with Arduino IDE 1.6 works

Hey PlatformIO´ers

I’m trying to switch to PlatformIO.
Exact the same wiring and code works perfectly fine with Arduino IDE 1.6.x. I’m using a USB-ISP.

I tried different settings, but always the same error:

Uploading .pio\build\attiny24\firmware.hex
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03

the platformio.ini is mainly from a german online magazin (Erste Schritte mit den Mikrocontrollern ATtiny84 und 85 | heise online)

board = attiny24
platform = atmelavr
framework = arduino
upload_protocol = stk500v1
upload_flags =
upload_speed = 115200
upload_port = COM5

Do I miss here something? THX for your help.

If that works, that’s great, because you can go to File → Settings and tick “Verbose Upload”, then upload again. The log should now show you the exact avrdude invocation. What does it say?


Thank you very much for this tip!

 Programmer Type : STK500V2
         Description     : Atmel STK500
         Programmer Model: STK500
         Hardware Version: 10
         Firmware Version Master : 2.10
         Topcard         : Unknown
         Vtarget         : 3.3 V
         SCK period      : 8.7 us
         Varef           : 3.3 V
         Oscillator      : 1.229 MHz

Now I changed in PlatformIO to STK500V2 and everything worked as in the Arduino IDE!