Atom spinning image on platformio install

So something went awry during my install of platformio on atom
It basically looks like platformio is hosed, all i get is that spinning icon when i select the plaformio home on atom.

I’ve tried to remove everything all platformio and atom related and reinstall again the same result, just that spinning logo and no information as to what it attempted to do (just the animated icon).

I have removed platform io from atom, removed atom. Following this i have reinstalled atom and the platformio packages the end result is that spinning icon. The next stage looks like i have to reinstall windows just to get this thing to reset to some default.

Please open PIO IDE Terminal and type

pio home

Do you see any errors?

Getting the same error as OP. When I use pio home from the IDE terminal, I get:

Traceback (most recent call last):
  File "", line 16, in init main
  File "", line 21, in init cmd_debug
  File "C:\Users\<user>\.platformio\packages\pysite-pioplus\twisted\internet\", line 30, in <module>
    from twisted.internet import _win32stdio
  File "C:\Users\<user>\.platformio\packages\pysite-pioplus\twisted\internet\", line 9, in <module>
    import win32api
ImportError: DLL load failed: %1 is not a valid Win32 application.

Please provide an output from system Terminal cmd

echo %PATH%
python --version
pip --version
pip list

Could you try to reinstall the latest Python?