Atom integration failure - Old bug resurfaced

something is messed up with my atom ( fedora 25, 1.16.0x64).
I reinstalled the atom ( removing the ~/.atom , ~/.config/Atom directories in between).
Installed the PIO ( using atom package install functionality) only ( no other additional packages has been installed).
Created a new directory and copied one cpp file into “src” directory. Init the PIO project.
But when i’m trying to build the project i’m getting “Please make sure the package “Build” is installed and activated” message. At the same time if i issue the “pio build” command in the terminal the project compiles successfully .

Is there anything i can check to understand what is broken?

P.S. In the atom->terminal
platformio --version
PlatformIO, version 3.4.0a6

But if i type the same outside the ATOM:
[az@toshiba ~]$ platformio --version
Traceback (most recent call last):
File “/bin/platformio”, line 7, in
from platformio.main import main
File “/usr/lib/python2.7/site-packages/platformio/”, line 22, in
import requests
ImportError: No module named requests

So it appears that i have 2 installations of PIO?
one ( working ) is in :slight_smile:~/.platformio/penv/bin/pio
and another in
which pio
[az@toshiba ~]$ which platformio

How is that possible that i have 2 PIO installed?

Anyhow i got rid ( pip uninstall ) of "Successfully uninstalled platformio-2.11.2

PIO build in Atom is still not working.
Uninstalled “Build” package; restarted ATOM; PIO installed BUILD; reboot - still no luck with building in atom with PIO…

another try:
a. uninstalled pio from atom.
b. rm -rf ~/.platformio
c. installed PIO from atom; restarted
d. same problem - unable to compile due to build problem.
e. go to Packages->Build -> Select Active Taret and get " the file is not the part of any open project in Atom"

Getting a big cold beer and retiring for the night…

It sounds like you have installed platformio on the command line, in addition to installing the atom plugin. This plugin installs and manages its own copy of platformio (and for recent development versions, it even installs its own python environment).

I have also occasionally run into the problem with the Build command not being installed, and this is on Windows x64. I haven’t been able to reproduce the exact circumstances to generate this problem, but I found that it also disappears at random as well.

I got reliable results by running platformio from the command-line, within a terminal launched under the atom plugin, which will use the atom plugin’s private python and platformio installation.

Two new observations:
a. PIO (integration with atom) is functioning fine under new (newly created) user
b. The example ( arduino blink) project, from PIO example projects works fine under the “broken” user

a. OS has nothing to do with the issue
b. This sounds like a problem i had before, when the path to the project was a “ln” which was confusing to pio. At the same time i can see that Atom makes “example” project active ( vertical blue line) whereas for non working projects it (line) doesn’t appear.

Aha! it is an old bug with the soft links.

To reproduce:
create a link to the project folder.
add project using the link
pio won’t work.

close project(remove project directory)
open project using non-linked path - pio works just fine.

Updated Bug #136

You probably are using Symlinks. This has caused me much pain in the recent past.