Atmel-ice unknown debug tool

I’ve been using platformIO for a few years. Today is my first time trying to use the Atmel-ICE with it.
I’m using the info from here, which looked quite easy, but it doesn’t work for me.
The project builds okay if I comment out the two atmel-ice lines from platformio.ini

platform = atmelavr
board = attiny85
framework = arduino
debug_tool = atmel-ice
upload_protocol = atmel-ice

But with those two lines not commented out when I build I get this:

Verbose mode can be enabled via `-v, --verbose` option
DebugInvalidOptionsError: Unknown debug tool `atmel-ice`. Please use one of `simavr` or `custom`:
  File "C:\Users\David\.platformio\penv\Lib\site-packages\platformio\builder\", line 173:
  File "C:\Users\David\.platformio\packages\tool-scons\scons-local-4.7.0\SCons\Script\", line 612:
    return _SConscript(self.fs, *files, **subst_kw)
  File "C:\Users\David\.platformio\packages\tool-scons\scons-local-4.7.0\SCons\Script\", line 279:
    exec(compile(scriptdata, scriptname, 'exec'), call_stack[-1].globals)
  File "C:\Users\David\.platformio\platforms\atmelavr\builder\", line 161:
    target_elf = env.BuildProgram()
  File "C:\Users\David\.platformio\packages\tool-scons\scons-local-4.7.0\SCons\Util\", line 251:
    return self.method(*nargs, **kwargs)
  File "C:\Users\David\.platformio\penv\Lib\site-packages\platformio\builder\tools\", line 61:
  File "C:\Users\David\.platformio\packages\tool-scons\scons-local-4.7.0\SCons\Util\", line 251:
    return self.method(*nargs, **kwargs)
  File "C:\Users\David\.platformio\penv\Lib\site-packages\platformio\builder\tools\", line 111:
  File "C:\Users\David\.platformio\packages\tool-scons\scons-local-4.7.0\SCons\Util\", line 251:
    return self.method(*nargs, **kwargs)
  File "C:\Users\David\.platformio\penv\Lib\site-packages\platformio\builder\tools\", line 233:
  File "C:\Users\David\.platformio\penv\Lib\site-packages\platformio\builder\tools\", line 197:
    % board_config.get_debug_tool_name(env.GetProjectOption("debug_tool")),
  File "C:\Users\David\.platformio\penv\Lib\site-packages\platformio\platform\", line 126:
    raise DebugInvalidOptionsError(
========================== [FAILED] Took 1.80 seconds ==========================

I have the ICE plugged into my laptop and it worked previously worked okay with Atmel Studio, but that was a couple of years ago.
Does anyone know what I’m doing wrong?

Hmm, maybe platformIO only supports it for ARM not AVR.
Initially I just saw this:

But on reading further it doesn’t seem to list any AVR boards

Correct. Debugging AVR chips with the Atmel-ICE tool is unsupported and quite frankly a mess, thanks to Microchip not releasing an open source GDB server, but only looking after their nice proprietary Micrchip Studio environment. See related posts like

The program “avarice” could potentially use your atmel-ice to connect to an ATTiny85. See and

Thank you for the link. I’ll take a look tomorrow