PlatformIO Community

Arduino libraries missing from library manager

I’m playing with a Wio Terminal, and to connect to WiFi it needs the following libraries:

This is described in their WiFi documentation.

In the Arduino IDE I can find all of these libraries.

In the PlatformIO library manager, I can only find:

  • Seeed_Arduino_rpcWiFi
  • Seeed_Arduino_FS

The rest I have to link to the GitHub repos.

Is there a way to get PlatformIO to pull these libraries in?

Some of these libs are available but you didn’t find them. For searching, you need to go to the library.properties file of the repo, then copy-paste the name=.. value into PlatformIO’s library searcher.

Available per https://platformio.org/lib/show/11656/Seeed%20Arduino%20rpcWiFi

Not available. @ivankravets can you please add it?

In any case, you can always reference the Git or ZIP downlink link per lib_deps to include the library.

lib_deps = 
   https://github.com/Seeed-Studio/Seeed_Arduino_rpcUnified/archive/refs/heads/master.zip

for example for the master version.

Available per https://platformio.org/lib/show/11674/Seeed_Arduino_mbedtls

Available per https://platformio.org/lib/show/11666/Seeed%20Arduino%20FS

Available per https://platformio.org/lib/show/11659/Seeed%20Arduino%20SFUD

1 Like

We can’t add a library from our side. The library author should publish it to the PlatformIO Package Registry using https://docs.platformio.org/en/latest/core/userguide/package/cmd_publish.html

1 Like

Thanks everyone!

@ivankravets - is this the norm? Do all authors have to add their packages to PlatformIO manually? Isn’t there a way to import them from the Arduino Library Manager?

I’m happy to contact the package author to get it added, I’m just surprised that all the Arduino package authors would have done this step.

If a library is listed in the Arduino registry, PlatformIO Registry will sync it.

Is it available in Arduino Library Manager?

Yup:

2021-03-20_11-20-26

See

1 Like

@ivankravets thanks! I had a feeling it would be something relatively simple like a configuration problem on the library side.

Appreciate everyones help here! I’m working on some introduction to IoT tutorials and I’m glad I can stick with PlatformIO for them.

1 Like

Let’s wait when PR be merged.

Thanks for using PlatformIO! :pray:

@ivankravets thank you for the PR.

The PR is merged now and I have created a new release so that platformIO Library Manager can sync with it.

Best Regards,
Lakshantha

2 Likes

Thanks! Library is available in our registry https://platformio.org/lib/show/11971/Seeed%20Arduino%20rpcUnified

Thank you!

Regards,
Lakshantha

Thanks everyone with their help here!

@ivankravets - I’ve come across another Seeed studios library that is in the Arduino IDE libraries list, but not in PlatformIO.

I’ve checked the library.properties file and @lakshanthad has fixed a broken email address, but it’s still not showing. Is there a way to get the reason why PlatformIO is not picking it up so we can fix the library.properties file?

Let’s wait when this PR will be merged

1 Like

@ivankravets I have merged the PR

Still not showing. Is a new release/version number/tag needed?

@jimbobbennett I have just created a new release. Will take sometime for the changes to come into effect

Still not showing. @ivankravets - any ideas?

Thanks for merging PR. The library was automatically imported to the PlatformIO Registry - Seeed Arduino Audio.