All of a sudden terminal will not start anymore

All of a sudden I get this error when I try and start terminal.
I am running Platformio/vscode core 6.1.2, home 3.4.2, on a Mac with Catalina 10.15.7., and have had no problems at all until…now.
I tried to restart vscode, the Mac, the usb interface… the problem remains.
Any hint on what to solve the problem???

This is the error output I get:

Error: Traceback (most recent call last):
File “/Users/gabriele/.platformio/penv/lib/python3.9/site-packages/platformio/”, line 102, in main
cli() # pylint: disable=no-value-for-parameter
File “/Users/gabriele/.platformio/penv/lib/python3.9/site-packages/click/”, line 1130, in call
return self.main(*args, **kwargs)
File “/Users/gabriele/.platformio/penv/lib/python3.9/site-packages/click/”, line 1055, in main
rv = self.invoke(ctx)
File “/Users/gabriele/.platformio/penv/lib/python3.9/site-packages/platformio/”, line 71, in invoke
return super().invoke(ctx)
File “/Users/gabriele/.platformio/penv/lib/python3.9/site-packages/click/”, line 1657, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Users/gabriele/.platformio/penv/lib/python3.9/site-packages/click/”, line 1657, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Users/gabriele/.platformio/penv/lib/python3.9/site-packages/click/”, line 1404, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/Users/gabriele/.platformio/penv/lib/python3.9/site-packages/click/”, line 760, in invoke
return __callback(*args, **kwargs)
File “/Users/gabriele/.platformio/penv/lib/python3.9/site-packages/platformio/device/monitor/”, line 143, in device_monitor_cmd
unknown_filters = set(options[“filters”]) - known_filters
TypeError: ‘NoneType’ object is not iterable


An unexpected error occurred. Further steps:


Known bug which was already fixed in Error when opening Serial monitor in VS Code · Issue #4363 · platformio/platformio-core · GitHub.

Please open a CLI and execute pio upgrade, then retry building.

Fixed. Thanks. I was getting the message that my Platformio was already up-to-date, but forcing the upgrade did do the trick.

I raised the topic today and am getting the same behaviour in VSC and CLI. Have tried everything that I can think of in terms of reloads, updates, deleting old versions.

Behaviour is the same in 6.1.5 and 6.1.6a4

Very frustrating as it looks like costing me a day of work:-(,

Same behavior meaning exactly same error message too?