After update PlatformIO it looks like it does not read platformio.ini

Last time I used PlatformIO for about a month ago. Now I started it again on Ubuntu it was as normal doing an update. After the update I was going to my main.cpp and did some small changes. Then I did a compile and upload. Then it tried to write to /dev/ttyUSB2 while in the ini file I defined 0. The workaround to connect first 2 other boards and then the one I want to program it did find the board, only now complaining that the chip is an ESP32 and not ESP8266 and also this is set to ESP32 in the ini file. I expect that something is going wrong with reading the ini file. I am running core 5.1.1 home 3.3.4

Recent extension versions have changed the way the active project is designated. You have to manually select it via the project environment switcher now. It’s probably set to an older project of yours in which you aren’t doing the code or platfomio.ini changes.

Thanks for the fast response, my guess is that it did read the first platform.ini file (alphabetic order)…

It looks with my first search that the documentation is not updated: “platformio.ini” (Project Configuration File) — PlatformIO latest documentation

I need to figure out how this works, my first read did not get any clue how to solve this yet. Are the howto’s for this change to make it working again as before?

I do not understand, If I go to the “PIO Home” → “Projects” → “myProject” → “Configure” all settings are correct. I have a tab with “wemos_d1_mini32” and all properties like platform, board, upload_port etc.

The documentation in regards to what is not updated? The link shows how one platformio.ini is structured, but not what platformio.ini / project is the active one when you hit the build button, that is in described in the link I posted.

Can you show a screenshot of the VSCode window with the file explorer sidebar opened, and the info which project you wish to build / upload? (Alt + PrntScrn do make a screenshot of the active window, Ctrl+V to paste in post)

Hi Maxgerhardt,

Is this a screenshot with the info?


The whole window would have been better, but in any case, if that project is your target project, and it has some env:xyz defined in the platformio.ini, then that environment and project name is also what you have selected as the active project at the blue bottom bar in VSCode, according to the documentation I first linked, yes?


Hi Maxgerhardt,

I have solved it. Previously the env was switched automatically when switching from project, now the “env:…” in the lower blue bar needs to be selected to the correct one, and that can still be the same as I was using before. Thanks for the support.