Adafruit Feather M0 won't find / upload/ have to keep using Arduino

I have had this problem all along really with the Adafruit Feather M0.

PlatformIO does the reset, then says ‘No device found on com9’.

It then leaves the devices with a pulsing red light.

Every time, if I upload a sketch from arduino, it revives it, and I can try again in PIO.

What I have found usually works, is if I hit the reset button on the Feather as soon as PIO says “forcing reset”, but since the last PIO update last week, or certainly since me trying to use it tonight, it’s pretty much hopeless. I’ve spent about half an hour now trying to upload stuff. Succeeded once or twice, failed about 15 times, including going back to Arduino IDE to load ‘something’, just to get out of the pulsing red light thing.

Any tips?

Do you mean that it worked before?

Hi Ivan. It previously worked more consistently if I pushed the Reset button right about the time that PIO said “forcing reset” during the upload procedure. I’m pretty sure last week, on the previous version, I was able to do this consistently over a 14 hour ‘learning to code’ session. Tonight, I am back at it, and I am strugging to compile/upload more than once in succession, regardless of trying the reset button trick or not. I had got used to doing that previously as it seemed to be the only way to consistently get it to upload.

now though, and the only thing I think has changed it the update that went on 2 -3 days ago, now it is proving very difficult.

It seems once the board goes into this red heartbeat state (erased ?) there’s no way to get PIO to do anything with it, but Arduino IDE programs it perfectly fine. after that, I am able to program it with PIO again.

Thanks for all your help Ivan.

As discussed, I think this was caused by a Serial Port Capture driver that had been left behind as a Class Upper Filter on the port. (hhdspmc64)

all working nicely now