Wrong Flash Size ESP8266

I have created a new project in PlatformIO. I picked the board “Wemos D1 Mini Lite”, which has 1MB of flash. When compiling the code, I see that it has been picked correctly:

CONFIGURATION: Redirecting...
PLATFORM: Espressif 8266 > WeMos D1 mini Lite
HARDWARE: ESP8266 80MHz 80KB RAM (1MB Flash)

However, when trying to flash this image to the esp8266 via HTTPUpdater, it keeps being identified as a 4MB target bin file:

Update error: ERROR[8]: Flash config wrong real: 1048576 IDE: 4194304

Is this a bug or am I missing something?

I have also tried overriding the build flags with:
build_flags = -Wl,-Teagle.flash.1m0.ld

Still the same result.

Could you as here Issues · esp8266/Arduino · GitHub ? I’m not sure that this issue is related to PlatformIO.

Is that build _flags line right? I think a ‘0’ was added where it doesn’t belong…

eagle.flash.1m.ld not

Not that I’m saying that’s the problem! :open_mouth:

Also, there is a github issue on this, so just linking that here…