Warning: Path is not a directory: "/home/ivan/.platformio/packages/toolchain-xtensa32/bin/xtensa-esp32-elf-gcc"

platform = espressif32
board = esp32doit-devkit-v1

Everything compiles and works. But all the time a message pops up that:

Path is not a directory: "/home/ivan/.platformio/packages/toolchain-xtensa32/bin/xtensa-esp32-elf-gcc".
I tried to add:
export PATH=$PATH:$HOME/.platformio/packages/toolchain-xtensa32/bin/
Entering the command:
xtensa-esp32-elf-gcc -v
I get the answer:
Using built-in specs.
Target: xtensa-esp32-elf
Configured with: /builds/idf/crosstool-NG/.build/src/gcc-5.2.0/configure --build=x86_64-build_pc-linux-gnu --host=x86_64-build_pc-linux-gnu --target=xtensa-esp32-elf --prefix=/builds/idf/crosstool-NG/builds/xtensa-esp32-elf --with-local-prefix=/builds/idf/crosstool-NG/builds/xtensa-esp32-elf/xtensa-esp32-elf/sysroot --with-sysroot=/builds/idf/crosstool-NG/builds/xtensa-esp32-elf/xtensa-esp32-elf/sysroot --with-newlib --enable-threads=no --disable-shared --with-pkgversion='crosstool-NG crosstool-ng-1.22.0-80-g6c4433a' --disable-__cxa_atexit --enable-cxx-flags='-fno-rtti -ffunction-sections' --with-gmp=/builds/idf/crosstool-NG/.build/xtensa-esp32-elf/buildtools --with-mpfr=/builds/idf/crosstool-NG/.build/xtensa-esp32-elf/buildtools --with-mpc=/builds/idf/crosstool-NG/.build/xtensa-esp32-elf/buildtools --with-isl=/builds/idf/crosstool-NG/.build/xtensa-esp32-elf/buildtools --with-cloog=/builds/idf/crosstool-NG/.build/xtensa-esp32-elf/buildtools --with-libelf=/builds/idf/crosstool-NG/.build/xtensa-esp32-elf/buildtools --enable-lto --enable-target-optspace --without-long-double-128 --disable-libgomp --disable-libmudflap --disable-libssp --disable-libquadmath --disable-libquadmath-support --disable-nls --enable-languages=c,c++ --disable-libstdcxx-verbose --enable-threads=posix --enable-gcov-custom-rtio
Thread model: posix
gcc version 5.2.0 (crosstool-NG crosstool-ng-1.22.0-80-g6c4433a) 

So the patch works. Why then after compilation the warning remains?

When you do something specifically, like e.g. compile or upload? Or is completely random when this message pops up? Where does it pop up? In the VSCode IDE?

Immediately after the opening of the project. And after compilation remains.

Try making sure you’re running the latest platformio core (currently 3.6.6) (platformio alien head → Miscellaneous → Upgrade PlatformIO Core or via the command palette) as I’m pretty sure there was a workout for that warning (introduced by the Microsoft C++ extension March update) was introduced there. I don’t seem to be getting it any more anyway…

Yes version 3.6.6.
An analog problem also occurs with projects on the ESP8266 processor

“Path is not a directory: “/home/ivan/.platformio/packages/toolchain-xtensa/bin/xtensa-lx106-elf-gcc”.”

Although the files are physically available on disk.

lol… I spoke to soon… next ESP8266 project I created started giving that same error.

And the error is correct… the path to a file is not the path do a directory now, is it? :laughing:

Looks like there’s more workarounds needed because of that stupid March C++ extension update! :frowning_face:

I understand correctly that this does not affect the correct operation? Wait fix?

Correct… it is merely a message coming from the C++ extension, complaining about formatting of the configuration file that it doesn’t like. You can safely ignore it.

Thank you for taking the time to answer.

1 Like