VSCode - Setting gdb command line (- -baud==)?

Hi Guys,

So I need to get --baud= onto the command line when running from VSCode.

So manually I can get it going like this:

pio debug -q --directory /Users/bob/.platformio/.cache/.piodebug-qc_d4a9f --directory /Users/bob/Development/teensy/TeensyTest -l 10 --baud=115200 -x .pioinit /Users/bob/Development/teensy/TeensyTest/.pio/build/teensy41/firmware.elf

When running from VSCode even with debug_speed = 115200 set I get this:

pio debug -q --directory /Users/bob/.platformio/.cache/.piodebug-l0ur2y2e --directory /Users/bob/Development/teensy/TeensyTest -l 10 --interpreter=mi2 -q /Users/bob/Development/teensy/TeensyTest/.pio/build/teensy41/firmware.elf

So the baud rate is not being set.

I’m banging my head against the wall here as this seems a simple thing but I just can’t find any info on it.

here is the PlatformIO stuff:

; PlatformIO Project Configuration File
;   Build options: build flags, source filter
;   Upload options: custom upload port, speed and extra flags
;   Library options: dependencies, extra library storages
;   Advanced options: extra scripting
; Please visit documentation for the other options and examples
; https://docs.platformio.org/page/projectconf.html

platform = teensy
board = teensy41
framework = arduino
monitor_port = /dev/cu.usbmodem79500901

build_type = debug
lib_deps = https://github.com/ftrias/TeensyDebug/archive/refs/heads/master.zip
build_unflags = -DUSB_SERIAL        
build_flags = -DUSB_DUAL_SERIAL
              -DDEBUG                   # Comment out to disable debugging.
debug_port = /dev/cu.usbserial-14410         # Teensy, computer and OS dependent -- NEEDS TO BE ADJUSTED
debug_tool = custom
debug_load_mode = manual
debug_speed = 115200
debug_server = 
debug_init_cmds = 
  target extended-remote $DEBUG_PORT
  define pio_reset_run_target
  tbreak loop
  define pio_restart_target
  echo Restart is undefined for now.

debug_init_break =

Anyone got any hints it would really be appreciated.