PlatformIO Community

VScode + PlatformIO + Quick Start from docs = No Home Button

On Linux PopOS (Ubuntu pedigree), release v21.04, with a fresh VScode install: 1.59.1 x64. Installed through a .deb package (not through a flatpak). I went through the extension’s sidebar to install PlatformIO extension. It installed, but it didn’t ask me to reload, but I watched the output log until it was finished, and then I reloaded VScode.

I noticed there is no Home button in the bottom left as the Quick Start guide Step 1 claims:
image

I found several posts, although from 2020 and earlier, where this was a problem, all talked about Developer tools, reloading, etc. So I did this too:
image

I have thought it was something else like this whole new thing about WorkSpace Trusts, so I explicitly trusted my home directory and tweaked the Settings JSON according to a bunch of other posts and googlings I found.

I still dont seem to get any new clues where to look next. It just doesn’t behave as the PlatformIO Quick Start docs is telling me to expect, nor do the dozens of other posts having the same No Home Button threads have similar errors or hurdles.

So are there other places I could look around for more evidence what the hang ups could be?

Sorry for the weird screenshot links, I tried to provide them, but the forum said I was too new, so I pulled the bangs out of the front to get around it. Hope that’s not frowned upon. :grimacing:

I corrected the images.

What is the current list of extensions in VSCode?

Have you tried a clean re-install? (Remove PIO VSCode extension, close VSCode, remove ~/.platformio fully, re-install PIO VSCode extension)

My installed extensions are as follows:
image

Yes, I did try a new install, including chasing down and deleting all the dotfiles I could find.

Try doing this:

  • Remove PIO VSCode extension
  • close VSCode
  • rm -rf ~/.platformio
  • Follow Installation — PlatformIO latest documentation to install the PlatformIO core
  • Open VSCode again
  • re-install PIO VSCode extension
  • let it install fully until you get the notification to restart VSCode.

Okay, followed that all, and yet clicking the Install button in VScode still does not prompt for reload. When I disable it and/or uninstall it, it does prompt for reload, but never for installing. I close and reload anyways (after it acknowledges that it’s finished installing and enabling the extension).

Back to where I started, but now with more virtual python environments. :grinning_face_with_smiling_eyes:

For good measure:
image

I also don’t remember all these workspace trust problems from my earlier vscode, so I’m guessing this is something in the recent version I have installed. Anyways… I found this setting potentially in the way. I put in some trusting overriding as such:

>     "extensions.supportUntrustedWorkspaces": {
>         "platformio.platformio-ide": {
>             "supported": true,
>         },
>     }

But even after reloading, that didn’t seem to help either.

HEY! I got the Home button to show up! I installed the previous version 2.3.2!

Apparently, the last version (v2.3.3 Last updated 8/14/2021, 09:00:19) is bad news for me. :man_shrugging:

But now I’m wondering if I need to go around and undo all that extra python virtual environment cruft that guy sprayed everywhere :frowning:

I’m running the PlatformIO extension version 2.3.3 on the latest VSCode (1.59.1), but have not attempetd a clean installation from that version. Please report the issue to Issues · platformio/platformio-vscode-ide · GitHub.

Never done that before. Any advice on doing so?

I mean, an issue is just a text describing the installation problem you’re having plus your environment. But I can also open that for you.

  • When you open a CLI and execute pio system info, what’s the output?
  • After installation on the lower extension version, can you upgrade the extension version and restart VSCode and it still works?

I think I figured it out… I’m really REALLY new to all this; I am not a developer, just someone who really wants to do more with STM32F* MCUs without using ArduinoIDE, because it doesn’t let me use all the stuff that’s available.

SO! I spun up a virtualbox of my linuxOS with NOTHING installed, but this time from the CLI did an:

apt install platformio* openocd stlink* --install-recommends

And then I installed:

apt install code --install-recommends

Then when I opened vscode, I installed the latest PlatformIO extension, and everything popped up like the Quick Start docs expected. So it seems I’m such a newbie, that I didn’t realize that I needed basic stuff installed even more I installed the extension in vscode.

Now I can go back to having no idea what I’m writing when it comes to STM32F* and HAL, etc. :smiley: