PlatformIO Community

Upload to Digispark Device not possible

Hello,

I am not able to upload a simple blink sketch to my Digispark device. I’m using platformio-ide 2.0.0-rc.3 within the Atom Editor on Manjaro Linux 64bit. Uploading to a Arduino Nano devices works without problems.

I am getting the following error message:

[Sat Oct 14 17:16:14 2017] Processing digispark-tiny (platform: atmelavr; board: digispark-tiny; framework: ard
uino)


Verbose mode can be enabled via -v, --verbose option
Collected 38 compatible libraries
Looking for dependencies…
No dependencies
Looking for upload port…
Please unplug/plug device …
Uploading .pioenvs/digispark-tiny/firmware.hex
*** [upload] Error -11
======================================================================= [ERROR] Took 1.37 seconds =============

Does anyone know what is meant by *** [upload] Error -11? I didn’t find any information for that.

Any help would be appreciated.

Please fill an issue here

It finally works now. I added the udev rules according to this page:

http://digistump.com/wiki/digispark/tutorials/linuxtroubleshooting

And I have to use a USB-Port directly on my computer. A USB-Hub doesn’t work.

Hello!
I was having an issue with that board on PlatformIO where the upload process did not wait for me to plug the board and it gave me this message:
Uploading .pio\build\digispark-tiny\firmware.hex
**** [upload] Error 309*
So I tried this:

  1. I installed the board drivers

  2. Upload a sketch in Arduino IDE (ver 1.8.13)

  3. Came back to platformIO and this time around it worked!

When I hit upload it shows me the message and waits for me to plug the device.
I don’t really know how or if this was definitely the thing that fixed the issue, buit I share it in case someone else find it useful.