Upgrade to 1.4.7 created Traceback and OSErrors


#1

The upgrade to 1.4.7 has resulted in the following errors. Everything was operating correctly immediately prior to upgrade reload. I am running macOs Mojave 10.14.1 and building for an Arduino.

Error: Traceback (most recent call last):
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/main.py”, line 120, in main
cli(None, None, None)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/click/core.py”, line 700, in call
return self.main(*args, **kwargs)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/click/core.py”, line 680, in main
rv = self.invoke(ctx)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/click/core.py”, line 1027, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/click/core.py”, line 873, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/click/core.py”, line 508, in invoke
return callback(*args, **kwargs)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/click/decorators.py”, line 16, in new_func
return f(get_current_context(), *args, **kwargs)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/commands/run.py”, line 107, in cli
result = (envname, ep.process())
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/commands/run.py”, line 207, in process
result = self._run()
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/commands/run.py”, line 313, in _run
return p.run(build_vars, build_targets, self.silent, self.verbose)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/managers/platform.py”, line 354, in run
self.install_packages(silent=True)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/managers/platform.py”, line 282, in install_packages
self.pm.install(name, version, silent=silent, force=force)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/managers/package.py”, line 692, in install
package_dir = self.get_package_dir(name, requirements, url)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/managers/package.py”, line 446, in get_package_dir
manifest = self.get_package(name, requirements, url)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/managers/package.py”, line 414, in get_package
for manifest in self.get_installed():
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/managers/package.py”, line 404, in get_installed
manifest = self.load_manifest(pkg_dir)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/managers/package.py”, line 364, in load_manifest
src_manifest_path = self.get_src_manifest_path(pkg_dir)
File “/Users/western/.platformio/penv/lib/python2.7/site-packages/platformio/managers/package.py”, line 335, in get_src_manifest_path
for item in os.listdir(pkg_dir):
OSError: [Errno 13] Permission denied: ‘/Users/western/.platformio/packages/contrib-pysite’

============================================================

An unexpected error occurred. Further steps:

============================================================


#2

Please remove this folder and kill all python / pioplus processes. Start VSCode.


#3

Thank you, it is working now.