Update maybe broke PIO- no buttons

I see there are release notes, so there’s an update.

The buttons have disappeared from the bottom. I see the logo in the left column, but no ‘build’,. etc.

Do you have a project open with a platformio.ini file? If not, you get the alien head but no toolbar with buttons.


1 Like

No toolbar.

Just VSCode.
When I hit the alien head, nothing happens.

I’m dead in the water.

Why does it arbitrarly decide not to show a file in tabs?

I’ll look at x from /src, then open the .ini, and the src file disappaears. Or I’ll look at one program, open another and the first disappears.

Yeah! VSCode got me like that for a while too. Most annoying.

If you click on a file, it displays in the editor and will open one tab. If you click another file, it replaces the existing file that was open in that same tab

Double-click a file however, and it opens in a new tab.


That’s great, but I won’t be clicking anything if I can’t upload.

Where did the toolbar go?
Am I the only one seeing this?

I’m here, because Arduino IDE just stopped working.
This can’t stop working.

I’m thinking something didn’t work in the upgrade. Mine, of course, worked.

Is anything listed under Help->Toggle Developer Tools, on the Console tab?

This thread shows a similar problem on a Mac, which was caused by Microsoft’s C++ extension, which PlatformIO depends upon. PlatformIO Toolbar and Home icon not showing in VSCode - #3 by daaron

I would also check that you have enough free disc space on your drive where VSCode is installed, and on your C drive where My Documents lives. Just in case.


Developer Tools only opens a preview pane with HTML in it.

I was really excited to finally get back to telemetry. I got ESP Now to work, so I was going to make a WeMos sensor pod and collect the data with my 8266 Mega, which I still haven’t uploaded anything to. I was just getting set to get the MAC address.

Then I was going to make a raw literal webserver- and I know HTML. That part is going to be super fun.

That was supposed to be my whole weekend.

The terminal process failed to launch: Starting directory (cwd) “C:\Users\joema\Documents\PlatformIO\Utilities” does not exist.

You need to look at the “console” tab on the html vieww that opens.

I just moved all of my folders around. The only ones in the current workspace are ESP Now and Utilities.

It’s telling me that your “current working directory”, which is where you are currently located, c:\Users\joema\Documents\PlatformIO/Utilities is missing.

It looks to be trying to execute something from there, and failing.

If you have moved stuff around, you might have renamed or deleted it? Have you exited VSCode and gone back in?


That’s artifact. I re-opened the folders.
Hitting the alien head, selecting Open gave me the PIO Home screen, but still no buttons.

I think my PIO has an F. I’m going to reinstall it from the website.

I uninstalled VSCode. Is there anytthing of PIO beyond the folder in Users?

I’m on Linux, so I’m not sure. Based on what I know, that’s probably all there is.


This is from the PlatformIO install inside VSCode:
[kit] Successfully loaded 0 kits from C:\Users\joema\AppData\Local\CMakeTools\cmake-tools-kits.json

That doesn’t look right.

Now this:
Bad CMake executable “”. Is it installed or settings contain the correct path (cmake.cmakePath)?

There is no upload button. There is no trash button. It says ‘No active kit.’
0 kits were installed. This installation is broken.

I’m told there are no compilers.