Unable to upload packages

Hi guys,
I’m hitting what seems to be a known bug : upload manager fails to install new versions. Here is the typical output I get either doing the upgrade through vscode or manually as per Redirecting... :

Processing uno (platform: atmelavr; board: uno; framework: arduino)
Tool Manager: Installing platformio/tool-avrdude @ ~1.60300.0
Error: HTTPSConnectionPool(host='dl.registry.platformio.org', port=443): Max retries exceeded with url: /download/platformio/tool/tool-avrdude/1.60300.200527/tool-avrdude-windows-1.60300.200527.tar.gz (Caused by SSLError(SSLCertVerificationError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1076)')))
The terminal process "C:\Users\marcosjl\.platformio\penv\Scripts\pio.exe 'run', '--target', 'upload'" terminated with exit code: 1.

I’m running VSCode/PlatformIO IDE on several computers, but this is only happening on my corporate laptop behing a corporate proxy. I made ‘dl.registry.platformio.org’ web site to be on the white list not to be decyphered (corporate proxy changes SSL certificates in this case).

But I cannot make it work.

Thanx in advance for any hint.
José L. Marcos

Indeed this is the problem. PlatformIO wasn’t able to verify the certificate of its site because the certificate chain was altered in transit. Same as in PlatformIO SSL error while upgrading using vscode. Maybe you can follow some pointers as outlined in PlatformIO IDE in VSCode can't connect to the Internet - blocked by Proxy.

Well… The thing is the download site presents correct SSL certificates.
I’m using a CNTLM local proxy on both linux station and windows 10 laptop in order to do some automatic logon to the corporate proxy.

No problems on the linux workstation, but still on the windows 10 laptop. The installed antivirus is not blocking the download…

So I’m puzzled !

How does the certificate chain look like when you go to https://dl.registry.platformio.org/?

Should be

Nope !
I need to check with my IT dpt to make sure that the white rule has been correctly implemented on the proxy.
Thank you for pointing me to that clue

It was not !
And will be implemented on friday… Hope this’ll correct the situation.