Unable to resolve configuration with compiler path ERROR and generating random files in projects

Hi everyone

I just started using Platformio and I am actually loving it. And today suddenly I started getting this problem first I got the Error message “unable to resolve configuration with compilerpath” and then random files are being generated in my project and also I am getting tons of error in my projects related serial etc

I am using arduino core with esp32

I have circled with red on random generated files in my project


Hi Haseebzaib,
I have the same problem. No luck solving it yet.
Any progress?

nope no luck. I reinstalled platformio, my project compiled once but again the problem came back

what problem are u facing same as mine ? is it generating random files and not compiling ?

Yes, same , compiler path error, random files in project… I reinstalled the visual studio. That helped

hmm I’ll then also uninstall vs code and reinstall

Same problem. Tried uninstalling and reinstalling, problem still there, can’t compile anything.

I uninstalled the vscode and deleted platformio folder also. After reinstalling everything now it is working fine. You should also try it

I had this same issue, nothing fixed it. See this thread

I tried vscode on another machine, same thing. However, when i logged out of my account on the other machine, disabled all extensions but the platformio and c++ extensions required by pio - the issue STILL happened. This told me the issue was not my machine, but my extension settings, so I went and checked the c++ extension - it was on the pre-release version. I switched to the release version - problem solved (for now). I am absolutely positive this was the cause of the issue. I tried everything prior, reinstalling vscode, reinstalling platformio (10 times might I add), checking user permissions, disabling windows defender, etc etc. Nothing worked. Check your c++ extension and ensure that it is on the ´release´ version, not the ´pre-release´. Then, delete the contents of the ´.platformio/packages´, ´.platformio/platforms´, ´.platformio/.cache´ folders and rebuild the project.

1 Like

“… Check your c++ extension and ensure that it is on the ´release´ version, not the ´pre-release´. Then, delete the contents of the ´.platformio/packages´, ´.platformio/platforms´, ´.platformio/.cache´ folders and rebuild the project.”

Yes this seems to work. You may get an error as it takes time to rebuild and you may have to do it for every project. Thanks zanzythebar


Wow, I have never seen that before. Do you have any antivirus active? Can you report that to Issues · platformio/platformio-vscode-ide · GitHub?

1 Like

CC @ivankravets please look at this and Problem with platformio.ini "creating some garbage files when I open any project that contain platformio.ini", this is unusual

1 Like

Hi @haseebzaib
That is unfortunate timing! I have been using PIO without issues (other than my own ignorance :wink:) for about 9 months - so much better than the Arduino IDE!

yes for now the problem is fixed by uninstalling vscode platformio and reinstalling it

true platformio is just so much better, now I could not even think about going back to arduino IDE but thankfully this issue is fixed for now

Hi @maxgerhardt
I have been chatting with Sean from MS in When I use vscode to open a folder, many empty file with invalid code automatically are generated. · Issue #145297 · microsoft/vscode · GitHub

Certainly down to that C++ pre-release but I still don’t know the full impact or how I got it!

1 Like

Definitely seems like it is Version 1.9.4 (pre-release) C++ extension automatically creates garbled files in the workspace · Issue #9041 · microsoft/vscode-cpptools · GitHub. They even have Don't install 1.9.4 (use 1.9.5, 1.9.3, or 1.8.4) · Issue #9046 · microsoft/vscode-cpptools · GitHub as a pinned issue now.