Unable to rename error


I have often Unable to rename error reason: File exists.
And the upload is cancel. What is the problem ?

With what procedure is that error reproduced?

When I use the upload button on VSCode.

Can you show a screenshot when that happens? What project are you uploading?

A screen project using TFT_eSPI library.

Do you have the exact platformio.ini and code where this error is happening?

This problem appear in many of my projects and with different board (stm32) but seems to be only when I use the Arduino framework.

I also tried to run VSCode as administrator but that didn’t works.

The only place where I’ve seen that in the forum is Include libraries properly - #3 by Nikosant03 where it was solved by doing a clean & rebuild.

Does the issue disappear after the next build or clean or is the project forever “bricked” then?

Yes for compile my code I clean and rebuild but it’s painful.
Thanks for your help

Maybe some antivirus program or the default Windows defender is interfering. See Hang creating new projects. Hang using pio install - #2 by maxgerhardt.

I just do that thanks, I will repost a message if the problem reappear.

I’ve still the issue.