Unable to flash my TM4C123GXL board (lm4flash: not found)

The following error shows when I upload the firmware into my board. I tried to download lm4flash from LMFLASHPROGRAMMER Software programming tool | TI.com but, that driver is not for Linux system. Any flash programmer available for Linux?
me@linux:~/Desktop/test$ platformio run --target upload
[Wed May 25 00:39:45 2016] Processing lptm4c1230c3pm (platform: titiva, board: lptm4c1230c3pm, framework: energia)

“/home/me/.platformio/packages/tool-lm4flash/lm4flash” .pioenvs/lptm4c1230c3pm/firmware.bin
sh: 1: /home/me/.platformio/packages/tool-lm4flash/lm4flash: not found
scons: *** [upload] Error 127
========================= [ ERROR ] Took 1.66 seconds =========================

Does http://energia.nu work for you? If yes, we will use their binaries. Thanks.

No. energia also not working.

Can not run program “/home/me/energia-0101E0017/hardware/tools/lm4f/bin/arm-none-eabi-g++”: error=2, No such file or directory

I checked for the file arm-none-eabi-g++. It’s there.

me@linux:~/energia-0101E0017$ find . -name arm-none-eabi-g++

Same for Platformio:
I checked for lm4flash file in my system. It’s there.

me@linux:~/Desktop/test$ ls ~/.platformio/packages/tool-lm4flash/

By the way I tried uploading in our office Ubuntu systems. It worked there perfectly.

What is your home distro?

It’s OK. It worked. I had to add 32 bit architecture and install some dependencies.

sudo dpkg --add-architecture i386
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386

I am using Ubuntu 16.04 64bit OS…

Thanks a lot for the solution. I marked this post as FAQ and I hope that it will be useful for others.