Unable to do remote upload

I’ve a problem with remote upload, pio monitor command is working and there is a successful connection between host and remote PCs in PlatformIO.

When I run the following command:
platformio.exe remote run --target upload

I got this error:

Uploading firmware remotely
(2, 'CreateProcess', 'The system cannot find the file specified.')

Also, on Remote Development Menu I see only two options, maybe it’s related to issue I reported above


Same with

pio remote run -t upload --force-remote


I got the same result with that command

What’s the platformio.ini? Is the remote computer a regular Windows PC?

It’s a regular Windows PC. Below is just part of the platformio.ini, I can’t paste the whole file because of some private data. It is important that code is built successfully and works when it’s flashed directly on the host machine and device.


build_flags =



board = esp32dev

framework = arduino

platform = https://github.com/platformio/platform-espressif32.git

platform_packages =



board_build.partitions = partitions_custom_16MB.csv

board_upload.flash_size = 16MB

board_upload.maximum_size = 16732160

lib_deps =


    vshymanskyy/StreamDebugger @ ^1.0.1



build_flags =  


monitor_speed = 115200

monitor_filters = esp32_exception_decoder, time

That’s a weird way of writing platform = espressif32@5.0.0, which would also give you Arduino-ESP 2.0.3. Is it any different with that?

Same result. I don’t even understand why this could create a problem when compiling process is successful and the local upload/monitor is working.