PlatformIO Community

TI LaunchPad (Tiva C):upload error

Hi,

I have been trying TI LaunchPad (Tiva C) tm4c123 (80MHz) with VS Code and PlatformIO. Could not upload the energia blink example to the board after successful compiling. The error message is as follows.

Processing lptm4c1230c3pm (platform: titiva; board: lptm4c1230c3pm; framework: energia)

Verbose mode can be enabled via -v, --verbose option
CONFIGURATION:
PLATFORM: TI TIVA > TI LaunchPad (Tiva C) w/ tm4c123 (80MHz)
HARDWARE: LPTM4C1230C3PM 80MHz 32KB RAM (256KB Flash)
DEBUG: CURRENT(ti-icdi) ON-BOARD(ti-icdi)
Library Dependency Finder -> http://bit.ly/configure-pio-ldf
LDF MODES: FINDER(chain) COMPATIBILITY(soft)
Collected 22 compatible libraries
Scanning dependencies…
No dependencies
Checking size .pioenvs\lptm4c1230c3pm\firmware.elf
Memory Usage -> http://bit.ly/pio-memory-usage
DATA: [ ] 1.6% (used 520 bytes from 32768 bytes)
PROGRAM: [ ] 0.9% (used 2324 bytes from 262144 bytes)
Configuring upload protocol…
Uploading .pioenvs\lptm4c1230c3pm\firmware.bin
‘openocd’ is not recognized as an internal or external command,
operable program or batch file.
*** [upload] Error 1

Please help, thanks!

For some reason it isn’t installing tool-openocd on it’s own (I got the same error when I tried just then).

You can manually install it at the PlatformIO terminal in VSCode via

platformio platform install titiva --with-package tool-openocd

and see if it works now… I don’t have one of those boards to try that myself…

1 Like

Thanks a lot! It worked like a charm.

Noticed under the platformIO folder, there was no openocd. I manually downloaded the files into that folder, but it did not work. Maybe need to include the path somewhere…

1 Like

Fantastic. Thanks for that :slight_smile: I’ve opened an issue on github so it can be resolved properly.

Fixed in https://github.com/platformio/platform-titiva/releases/tag/v2.0.8

Please update dev/platform.

1 Like

That’s great! Thank you!

1 Like