PlatformIO Community

The terminal shell "my folder" CWD does not exist

New install of VS Code with Platform IO extension on Win10 with domain connected user account.
Create an ESP32 project from PIO

Try to build project.

Executing task: C:\Users\me.platformio\penv\Scripts\platformio.exe run <
The terminal shell CWD “\DOMAINSERVER\RedirectedFolders\me\My Documents\PlatformIO\Projects\WAYO_CD” does not exist

launch.json had

“executable”: “/DOMAINSERVER/RedirectedFolders/me/My Documents/PlatformIO/Projects/WAYO_CD/.pio/build/esp32dev/firmware.elf”,
“toolchainBinDir”: “C:/Users/me/.platformio/packages/toolchain-xtensa32/bin”,

I changed /DOMAINSERVER/RedirectedFolders to C:/me :no change
Tried setting terminal.integrated.cwd to c:\temp : no change
Disabled PIO :no change

I can’t find where VSC is getting the /DOMAINSERVER/RedirectedFolders/me from

  • note DOMAINSERVER and me are redacted names.

I have been able to create a project where if I override the ‘Location’ when creating a new project to a local folder (ie c:\app\test) then I could get it to compile.
Downloading test projects though places them in the redirect folder which causes the compile error.
I tried changing the PIO default folder with

pio settings set projects_dir /new/path/projects/dir

This fixed one project but not another.

VS Code version: Code 1.40.2
OS version: Windows_NT x64 10.0.17763