PlatformIO Community

Suddenly everthing stopped working

Hi,
Today, I wanted to upload my program, but nothing worked, I have tried everything, and I dont have a clue why it stopped working, I have multiple BLE projects, and I tried every one of them, 2 of them still work, and 2 of them dont. The problem seems to be that initializing the MBED BLE API never returns.

but the strangest thing is, that It does work, as soon as I merge my bootloader into the resulting userfirmware.hex.
Is there anything that changed during the last days/weeks that could be the cause?!

Did you a platform update? What version where you on before?

1 Like

Even better, what is the error you’re given? Either a copy of the log or even a screenshot would help!

@maxgerhardt at least I did not actively start one, I dunno if it updatet itself platform NRF52 @ 3.5.0
@pfeerick I dont get any errors, it seems to compile and upload without a problem, It just doesnt do anything afterwards.

HOORAY! I found it! there somehow must have been some sort of update, because my custom linker script got overwritten, and thus the Softdevice didnt have enough ram for my needs! FIXED!

1 Like