Specific mbed version

after the last PIO update, it seems that I am not able anymore to set for my project to use a specific mbed release instead of the latest mbed release.
Could someone please give me a step by step guideline on how to do to use a spefic mbed framwork version, I am desperate, because my project does not work anymore
(FYI developing on ST nucleo stm32F303RE)


So how exactly did you set it up to get a specific version? And what does “not work anymore” mean? Compile error, runtime error? Needs more info.

1 Like

The problem, is that I had done it some time ago, and I do not rememeber exactly what I had changed.
In the folder .platformio\packages\framework-mbed@5.51105.190312 there is the version of the mbed lib I want to use, I must have copied there.
I remember also to have changed some lines in a json config file or in the platformio.ini, I am not sure which. And it worked. Since I got back form holiday, it compiles fine but it does not work anymore because it uses the most recent version of mbed which is not compatible w/ my project.
I was not able to find information in this forum or in the manual about the exact procedure to use it.
Please help me! I need the steps to follow to use a given version of a mbed framework, either local or form an online repository.

thank you

Could you try this version of dev/platform:

platform = ststm32@~5.3.0

It uses ARM mbed OS 5.11.5. See Releases · platformio/platform-ststm32 · GitHub

Great! Thank you. It worked like a charm.

By the way is there a way to select a given mbed framework independently form the platform?
Does this question have any sense?