Some files with extensions .txt or .md not displayed in project file list

I feel like this must be a really dumb question but I’ve yet to find an answer.

I am having trouble with some files ending with .txt and .md not showing in the file list of my projects (left pane within Atom, on MacOS). The readme.txt in lib shows up as do the and files. However I have added a few other files (tried both .txt and .md) and they will show up very briefly in the list and then disappear. An example would be a file named Notes.txt. The files are within the project folder on disk, they just don’t show up in the list in PlatformIO’s project tab.

Some .txt files that fail to show I copied in, I have also created some using the Add File in PlatformIO and both paths lead to the files not showing up.

I did some checking and it appears that if I add a file to .gitignore then once it is committed to Github that file will no longer be displayed in the project. How can I change this behavior?

For example, I have a header file with secret credentials which cannot be sent to Github. So I place that file in .gitignore. But after doing so I can’t see or edit it within Atom/Platformio. Same for some private files of notes etc related to the projects.

Just uncheck Atom -> Settings -> Core -> Exclude VCS Ignored Paths.