[solved] Why doesn't the esp-01 module works correctly with PlatformIO IDE

Hello, I’m trying to upload a code to the esp-01 module using PlatformIO IDE but when it’s done only the tx led gets high and nothing else happens. When I upload my code from the Arduino IDE it works as expected.

1 Like

Hi @FPablo!
Could you provide your code to reproduce the issue?

Hi, yes, I could:


Hm, I couldn’t reproduce your problem. With my ESP201 (it’s similar to ESP01) your code works perfectly:

platformio serialports monitor -b 115200
--- Miniterm on COM5  115200,8,N,1 ---
--- Quit: Ctrl+] | Menu: Ctrl+T | Help: Ctrl+T followed by Ctrl+H ---

Are you using latest framework version?

Yes, I get it (1.203?). I’m working with platformIO version 3.0.0.dev3, is it ok?

That might be the problem because PlatformIO 3.0 is still in development.
Could you try your project with 2.11.1?

Hm, ok. I will try it. But I want to know if this change will remove all the changes I do to other platforms?

I just tried your project with 3.0.0.dev12 and it works well.
Please update your PlatformIO to the latest development version.

How can I upgrade to that version? I only be able to upgrade to 2.11.2.dev3

Do you use PlatformIO IDE? Run next command in the built-in terminal:

pip install https://github.com/platformio/platformio/archive/feature/platformio-30.zip

PlatformIO 3.0 has not been released for beta testing. Please don’t use it and revert back to stable 2.0

pip uninstall platformio
pip install platformio
pio --version

In the version 2.0, could I edit the platforms and frameworks like in version 3.0?

With the upgrade the issue was solved. Thanks.

Do you mean to edit this GitHub - platformio/platform-espressif8266: Espressif 8266: development platform for PlatformIO?

No, PlatformIO 2.0 doesn’t allow it.

Ok, if you want to play with PlatformIO 3.0, see installation section here PlatformIO 3.0 Roadmap · Issue #423 · platformio/platformio-core · GitHub

Also, please backup ~/.platformio/platforms (if you have made changes here) and totally remove this folder. PlatformIO will install the latest version of the required development platform.

Does it work now?

Yes, it works. But, now I can’t compile the some libs added in the lib folder.

That is very interesting. The Library Dependency Finder has been rewritten from the scratch. Need to test it.
Could you share somewhere your project or make test project to reproduce this issue?


I solved the problem (this problem appeared with the ststm32 platform and some libraries that I wrote for arduino compatibility) and it was because of the libraries compatibility and the reserved word Arduino (?) that seems to appear in this new version.

Thanks for your help.

Ok, now I have a problem compiling this project:


On Arduino IDE, it compiles without problems.

This is documented in http://docs.platformio.org/en/feature-platformio-30/projectconf.html#projectconf-lib-compat-level

1 Like

@valeros, could you test this project with the latest PlatformIO 3.0?

Hi @FPablo! I could not compile your project in Arduino IDE as well. It fails with the same errors.
Do I need any special preparations?