Sodaq autonomo not detected for SAMD21J18A


We have custom board with SAMD21J18A, we tried to install sodaq autonomo bootloader.
But its unable to install.
Please give some suggestion for the same.

How, with that little information? :smiley:

What exact command are you executiong or what button are you pressing in which IDE, causing which error message to occur?

Thank you Maximilian,

Sorry for the incomplete data.
The procedure which i have followed for the microcontroller SAMD21J18A in VS code UI is

  1. Added sodaq_autonomoin arduino ide (via preferences and board manager).
  2. Set board as sodaq_autonomo selected programmer as Atmel ice.
  3. All other required components are on board already.
  4. Connect SAM ice to development board via 10 pin programming connector.
  5. Connected Atmel SAM ice programmer to pc
  6. Press burn boot loader. Boot loader burnt successfully. After that i connect it to pc via native USB board… no comport detected.
  7. If I double press reset switch BOSSA port detected. If I press reset again once after repeating same no BOSSA port detected and also no com port.
  8. Have to load boot loader again.

I think after the bootloader is burned you at least have to upload a sketch that opens the SerialUSB port.

Do you mean to upload any sketch like configuring any GPIO and try? If it like so then i have uploaded one sketch.

No I mean a sketch doing at least

#include <Arduino.h>

void setup() {

void loop(){}

You might also want to open an issue at Issues · SodaqMoja/SodaqCore-samd · GitHub as the people who wrote the core should have a better understanding of the bootloader and USB.

Yes we have tried .

Individual it is working.

But when i will add marlin firmware and also include sodaq bootloader, then sodaq bootloader won’t work.

So in that case, what can be the cause?