PlatformIO Community

SKR 1.2 failed with exit code 1 for this dummy

I want to enable bed PIDs on Marlin 2.0 Bugfix & change Y off-set for the nozzel. Using VS I’ve got to the point of sorting the config/h bit out but when I run the check/complier thing it leaves me with,

The terminal process "C:\User\roola.platformio\penv\Scripts\platformio.exe ‘run’ " terminated with exit code : 1.

I’ve had a look around for this & seen some possible solutions(?) but it’s leaving me cold.
Need a solution that this dummy can follow. Any help gratefully received.

So what are the error messages before that? This just says “An error occurred :frowning: .”

All I have above it is a load of ‘IGNORED’ statements in white.
eg LEDGERS IGNORED etc etc

Interestingly I can’t open Google Chrome & gives this :

C:\Users\roola\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\Google Chrome.link

The application has failed to start because its side by side configuration is incorrect. Please see the application event log use the command line sxstrace.exe for more detail

I’m writing this on a separate computer

What exact configuration changes did you make in the Marlin configuration? Can you upload your project so that it’s reproducable?

Ok, I uncommented the PIDBEDTEMP,on line 517
& set Y_MIN_POS to -30 , on line 1122

And that is all.

Not exactly sure about uploading; to the printer? Or what? I compiled it to see if it would upload. I retried compiling & got the same message.

Sorry, I’m pretty green at this & the language everyone uses confuses me still. I’ve got this far learning by youtube ‘rote’. I tried this on Arduino IDE as I could do this with Marlin 1.9 on my Anet but found out that Arduino can’t handle 2.0 etc. ATOM failed me too. I’m running out of options. Thanks for being there.