SD Card Recognises 16GB but not 32GB cards


Standard wiring, tried everything I can think of (voltage, reformatting cards…etc.). It is a weird issue where a standard SD.h inclusion is used and a standard SD code…when you plug 32gb card ite reports following:
[ 1277][W][sd_diskio.cpp:547] ff_sd_initialize(): APP_OP_COND failed: 1
[ 1277][E][sd_diskio.cpp:802] sdcard_mount(): f_mount failed: (3) The physical drive cannot work
1970/1/1 00:00:01 [INFO] Failed to mount card.

Insert 16GB card in the same module…works like a charm.

Now this is where it gets twisted…I had a few 32GB cards work no problem but most of them do not.

All cards are straight out of a packet.

The only conclusion is that the library is an issue that does not recognise 32gb cards. so…I have done the following in ini file:

platform = GitHub - platformio/platform-espressif32: Espressif 32: development platform for PlatformIO
platform_packages = platformio/framework-arduinoespressif32 @ GitHub - espressif/arduino-esp32: Arduino core for the ESP32

Packages got updated but the issue is still the same.

This has been tested across two brads of SD card readers and with a dozen SD cards straight out of a packet and at least 5 ESP32 with VCC from computer of 4.98v and battery 3.7 and 3.3 v pins.

Also tried defining HSPI interface and VSPI interface as well as initiating SPI with defined pins…also tested SPI pinout and system one matches wiring.

Any help is much appreciated as I am running out of ideas…

Many thanks