Running :make in VIM replaces the open file


I’m new to platformio, and some of the features in VIM that I have added as per the document here: Redirecting...

Things are generally working, however when ever I run :make, the open file is replaced (say main.cpp), with a file containing half the date (eg: [Thu Jun 14 13). I’m on a Mac, and have tried MacVim 8.1, 8.0, and vim, all with the same result.

Doing the same test with a very simple “hello world” C program, things run fine.

I have also tried resetting my .vimrc (removing), and moving my .vim folder, and still the same result.

I’m sure this is a noob question, but I have not been able to find anything about this in all my searching (probably searching for the wrong terms), I have read through the help pages for :make in VIM, and gone through a number of other setup processes.

Any guidance appreciated!


Could you check this issue? Is it the same?

That certainly sounds the same! I’ll do some quick hacking on the platformio code when I get a chance and see if changing the time format (removing the :) will sort things…

This issue can be considered closed, I’ll move all future discussion to platformio core run create a unwanted buffer on vim · Issue #1343 · platformio/platformio-core · GitHub

Thanks for your help!

Fixed in