Proxy Issue in VS Code

I’ve been trying to get PlatformIO installed through VS Code behind a proxy server. It seems to download ok but then it has the message Failed to install PlatformIO IDE

In the developer tools under console I’ve noticed that the first “red” error is cannot read property ‘headers’ of undefined in reference to workbench.main.js

There is also mention of failed to download file virtualenv-16.0.0.tar.gz and unable to verify first certificate

I’ve tried to install the virtual environment manually and it seems to do it, but no joy in VS Code :frowning:

There is reference to refused to connect and the following address is what I get when I put my password for the proxy in incorrectly but haven’t been able to get around it to have a pop-up or something similar to be able to put my credentials in.

Any help would be greatly appreciated

So what I’ve managed to do was get the contents of the .platformio file and copy that to a new machine in the same location and it’s worked as a “manual” install, still need to attempt to install PlatformIO through VS Code.

I forgot to mention this is on a Mac!

Also setting the following helped in the user settings
“http.systemProxy”: “on”,
“http.proxyStrictSSL”: false

Please try this solution

Hi Ivan,

I did try this, and found it still didn’t work behind the proxy we have here, not sure why.

The way around it I found above worked and also installing code in command PATH had to be done as well to be able to access extra libraries and boards, this step required admin privileges which students don’t have so I had to do this manually . It’s a long way around but it’s stable and doesn’t require students having to make sure they launch VSCode with their proxy details each time.