Problem with PlatformIO installation on VSCode

Was one of the ways downloading Download Python | Python.org, adding it to the PATH (option during the installer) and restarting the computer?

Thanks for your reply, I did it.

  • I pressed the button I have Python and gave it the path.
  • I uninstall python and Install again check the box for include the path.
    nothing change.

Uninstall the PlatformIO VSCode extension and make sure that when you open a shell (Windows + R -> cmd.exe), python --version returns your installed Python 3 version. If that’s not the case, reboot your computer; If it’s still not there, then python is not in your PATH and you should reinstall it or fix your path. When you can successfully execute python3 the plugin installation should go through.

If there are still problems we need more details on your OS and how you installed VSCode. I’m assuming Windows here.

I did what you suggest, I have Python installed and there are still problems with the extension.

3.8.6rc1 is a bleeding edge release candidate. Have you tried with the latest stable 3.8.5?

Yes I did, and the error still there.

On which VSCode version is this?

8

this message appears after the extension can not find python.exe, even putting the full path to the python.exe

TypeError [ERR_INVALID_ARG_TYPE]: The “path” argument must be of type string. Received type undefined
at validateString (internal/validators.js:112:11)
at Object.dirname (path.js:583:5)
at t.value (c:\Users\Davis.vscode\extensions\platformio.platformio-ide-2.1.0\node_modules\platformio-node-helpers\dist\index.js:1:29951)
at processTicksAndRejections (internal/process/task_queues.js:94:5)
at async t.value (c:\Users\Davis.vscode\extensions\platformio.platformio-ide-2.1.0\node_modules\platformio-node-helpers\dist\index.js:1:27882)
at async t.default.install (c:\Users\Davis.vscode\extensions\platformio.platformio-ide-2.1.0\dist\extension.js:1:23075)
at async c:\Users\Davis.vscode\exte…

The latest PlatformIO IDE 2.0 for VSCode comes with the new PlatformIO Core installer that contains portable Python. There is a problem with your system (permissions, antivirus, etc). Do you use any insecure software such as kaspersky, avast, macafee, etc?

I found may way here because it’s my 1st day using VSCode/PIO and I just have a habit of stepping right into whatever problems exist.

I tried installing a library using a PIO command while I was in a project workspace and it doesn’t exist. I have never installed Python on this machine.

I do however have Mcafee installed. I would have never thought that could be a problem. Do I need to exclude some directory (or something?).

Please keep in mind I don’t know VSCode/PIO like you do.

I saw another one of your posts where you mentioned a PIO backend Service but you didn’t include information about where or what it is that I need to whitelist in the firewall. Can you send me to a resource that explains this better?

Could you try to exclude %USER_HOME%/.platformio from your espionage tool that steals data from your machine?

1 Like

You’re pretty hilarious but who isn’t trying to steal our datas.

I’ll try that.

1 Like

I really appreciate you taking a minute to get me back on track.

You should know this

1 Like

Not me! :stuck_out_tongue:

It is quite annoying though when you install something, and the anti-malware/anti-virus/anti-make-my-computer-usable app decides to make its presence known (or not known, but the effects of it’s presence known)… and not in a good way. I used to have Bitdefender installed… it worked ok, but it was a bit too over-eager in silently blocking every single executable used to compile stuff, and get even more annoying when you changed boards or platforms, and had to go through one by one and unblock stuff as it blocked it.

1 Like

I actually cancelled MacAfee because their solution to exclude folders was “You can’t because we say so”. I’m a grown ass man and will take responsibility for what I do and own up to my own bad decisions because I’m a glutton for failure since it’s the only way I ever learn anything.

1 Like

Hello everybody here i just want to comment that yesterday 25-03-2021 i had the problem to install platformIO using Vscode. All i do is to dowload Python from Microsoft store but before that i erased the .platmormio folder C:/Users/user/.platformio and the other platformio folder inside vscode folder. So to read your comments helped me too much. Good luck.

Hi guys! I have a similar problem (using windows 10 pro) where when I try to install platformIO on visual studio code the home menu is not created and neither is the bottom menu bar. All that is done is that the bottom menu bar goes from purple to blue.

I also get a warning (only once per install) saying that “the extension ‘PlatformIO IDE’ took a very long time to complete its last operation and it has prevented other extensions from running.”

When “saving as” a file, it usually takes about 15-25 seconds which I think takes a lot of time. This is my first time using VSC so I don’t really know if this is normal or not.

When trying to open the platformIO home from the view->command palette->PlatformIO:Home I get this error message:

What I have tried:

Specs (I don’t know if relevant):
CPU: AMD Ryzen 7 3800X
GPU: GTX 960
RAM: 32GB DDR4 3200MHz

I appreciate any help I could get to figure this out and I wish I could attach more than 1 photo. Thanks!