Problem with PlatformIO installation on VSCode

When you open VSCode, do you get the following in the terminal panel every time VScode opens?

Installing PlatformIO Core...
Please do not close this window and do not open other folders until this process is completed.
Failed to install PlatformIO IDE.

i.e. does it think it needs to install still?

And can you have a look that this issue, and double check it doesn’t apply to you?

I’ve opened this issue on GitHub so it can be investigated further.

Hi, The problem is not similar to the one that you have mentioned, platformIO seems to install correctly without issue (I do not know how to read the extension installation logs) but once it the platformIO extension is installed it shows uninstall icon.

Regarding the platformIO after installation it does not even load at all, even I reopen vscode no home icon or anything else it fails in the very first stage of loading and generates the errors that I have mentioned earlier.

still I would like to know if there is something that I can figure out more about the issue?
Thanks in advance

I thought as much…

You could try opening the developer tools console again, and then go View -> Command Palette -> reload window (Developer: Reload Window`) and see if there are any startup errors… e.g. this is what my startup looks like…

I have done Developer: Reload Window in the command pallate and I got following

I get following when I execute PlatformIO: Home

  1. Try to uninstall all Python interpreters from the system
  2. Install the Python interpreter as described at Redirecting...
  3. Remove USERPROFILE/.platformio folder
  4. Restart VSCode.

Hi ivan,
I partially solved the problem as follows,
(1) Uninstalling all the python installations in Windows
(2) Checking if the Python 3.8.0 (64bit) is in the windows path
(3) Taking out all the previous path related to Python
(4) Uinstalling the PlatformIO extension in vscode (if exists)
(4) Erasing all the following folders
(5) Re-installing the platformIO extension inside the vscode
(6) Reloading vscode.

----------------- All works fine and the platformIO home does show up but following error occurs --------------
Following error occures when I am going to login into platformIO account.
Could not load PIO Account information

PIO Core Call Error: “spawnProcess not available since pywin3sdd2 is not installed.”

I do not know if there is any remedy for the login issue or not?
Thanks in advance


Thanks, fixed! Please open PlatformIO IDE Terminal and type pio update or VSCode > Left Sidebar > PlatformIO > Update…

1 Like

Would you mind show me (screenshot) where I can Update platformIO,
Both in terminal (in my terminal there is no pio in the env path).
Will you update the fixed version of platformIO on the VSCode website too.
Thanks in advance

There is a terminal icon on the bottom toolbar


1 Like

I have the same problem. New Windows 10 laptop, nothing else of relevance installed.
Tried to install, uninstall, reinstall, and delete .platformio folders many times.
I installed latest python (3.8.1, installs 32bit) and made sure it’s in the PATH.
PlatformIO installs correctly, “alien” icon shows up, but no commands in toolbar nor on left box (see picture)

command palette shows commands (e.g. “build”) but when I select it from command palette, I get error “command ‘’ not found” (see pic for “alien”, platformio versions, lack of icons / commands and error in lower right)
I’ll check the debug console but maybe someone can already tell me where to look … thanks

Error: Error: Command failed: global --encode-path " " -f "c:\Users\Massi\Dropbox\___STARTUPS_VARIE\CODE\PlatformIO\CheckPins\src\main.cpp"'global' is not recognized as an internal or external command,
operable program or batch file.
 `global --encode-path " " -f "c:\Users\Massi\Dropbox\___STARTUPS_VARIE\CODE\PlatformIO\CheckPins\src\main.cpp"` (exited with error code 1)

ok, what seemed to solve for now is this (I have all my platformio projects in a dir that is synced among computers via dropbox). I am used to open the containing folder as a workspace, as it worked on my old laptop. Like this.


and so on. so opening WORKSPACE_FOLDER as either a workspace or a folder works on old laptop but not on new one.

This does not work on new laptop. Both laptops are running same sw version of everything, but there must have been something that made the difference. Maybe because in the old laptop i “grew” my project dir and workspace one at a time?

anyway, by doing what was suggested here, I managed to get platformio to work for now.

  1. open just one of the projects as a folder e.g. WORKSPACE_FOLDER\PlatformIO_prj1. PlatformIO commands should be available now.
  2. add all other project folders inside WORKSPACE_FOLDER as extra folders. so far, if I try to include WORKSPACE_FOLDER itself, PlatformIO will stop working again.

Hope this helps in troubleshooting / making a future better user experience

1 Like

You need to open PlatformIO Project per workspace. Extension looks for platormio.ini file in the root of project folder.


You can’t open the WORKSPACE_FOLDER directly for multi-root projects. You need to do what you did… open one of them, and then add all the remainder, which you should be able to do in one hit, since you can either drag them all into the file explorer panel, or multi-select in the Add Folder To Workspace... dialog.

By opening the WORKSPACE_FOLDER directly, VSCode doesn’t treat it as multiple independent projects/folders, hence why it doesn’t work, and why the PlatformIO extension doesn’t see the requisite platformio.ini in the root of the folder.

1 Like

@ivankravets @pfeerick thanks!

1 Like

Hey mates, I am trying to install platformio on my vscode and I am getting this error, “PlatformIO: Can not find working Python 2.7 or 3.5+ Interpreter. Please install the latest Python 3 and restart VSCode” I did what the message suggests, I did try in many ways with no luck.
could you please give me a hand?.

Was one of the ways downloading Download Python |, adding it to the PATH (option during the installer) and restarting the computer?

Thanks for your reply, I did it.

  • I pressed the button I have Python and gave it the path.
  • I uninstall python and Install again check the box for include the path.
    nothing change.

Uninstall the PlatformIO VSCode extension and make sure that when you open a shell (Windows + R -> cmd.exe), python --version returns your installed Python 3 version. If that’s not the case, reboot your computer; If it’s still not there, then python is not in your PATH and you should reinstall it or fix your path. When you can successfully execute python3 the plugin installation should go through.

If there are still problems we need more details on your OS and how you installed VSCode. I’m assuming Windows here.