Problem upload code to ESP8266-01 (1M) using PL2303

I tried upload code to ESP8266-01 using PL2303 but it uploaded fail. This is problem when i uploaded:

You show a platformio.ini for a ESP8266 project but the output shows it’s trying to use AVRDude for an AVR project.

You also show that you have two projects in your workspace, “Test” and “ESP8266_01”, but as you can see in the blue status bar you have currently selected “Default (Test)”, so, the first project.

Just switch to your new project as described in the documentation and retry.

thank you for your help! I’m a beginner with Platform.I/O so I don’t have experience.
I just moved “Test” project in the workspace and then tried to upload code, it almost worked, but I have a another problem. Can you give me your help? Thank you so much!!

Okay now it uses the right project and right tool ( but the tool is not able to connect to the serial port.

Either your PL2303 serial adapter is damaged or you have connected it in a wrong way to the ESP8266.

How did you connect it? Any wireup diagram available?

It looks more like a problem between the serial adapter and the PC. Is it really connected and is it still called COM4?

The funny thing is that in the first screenshot you can see that PIO autodetected COM4 so it must be there, but then avrdude says it’s not there. Very likely a wiring problem, also observed in No text on OLED 128x64 from ATTiny85 - #7 by hans with the exact same adapter type (PL2303).

There is how to I wired them:
ESP8266 ----> PL2303:
Tx -----> Rx
Rx -----> Tx
GND ------> GND
3.3V ------> 3.3V
GPIO 0 ------> GND
Enable ------> 3.3V (my mistake when I using Keyboard!!)

this is PL2303 I using

I assume this is your CH_PD / chip-powerdown pin. This mist be HIGH. (see Flashing NodeMCU Firmware on the ESP8266 using Windows | Random Nerd Tutorials).

But it shouldn’t cause these kind of problems of “device not found”.

Can you disconnect the ESP8266 from the serial adapter and re-plug it into the computer, then upload? It should say something like packet header timeout becausae the ESP8266 is not there, but not device not found. If that error comes up, your serial adapter is faulty…

My mistake!! Actually I wired with HIGH but I wrote wrong!! I’m so sorry about that!!
Actually, I wired HIGH and I hadd the problem!!

What happens when you try this?

It still had this problem:

I think port had problem, I install CH340 driver, ver 3.5.2019 but I still had problem :frowning:

But the CH340 is a completely different chip and doesn’t affect this serial adapter.

Have you tried installing

EDIT: Yeah the problem seems to be that adapter though, the vendor says


  • Windows 8/8.1/10 are NOT supported in PL-2303HXA and PL-2303X EOL chip versions.
  • Run PL2303 CheckChipVersion tool program in Windows XP/Vista/7 to check chip version.

And even the USB COM port description says “PHASED OUT SINCE 2012”.

I would recommend a different adapter, e.g. FTDI based.

Thank you very much for your help!!! I installed PL2303 driver, so now I can upload to ESP8266_01