Problem installing the platformio on W7

I installed platformio on W10 without problem on my portable computer but I have issues on W7.

It shows: Error: Traceback (most recent call last):
File “C:\Users\Georgina.platformio.cache\tmp\”, line 69, in
File “C:\Users\Georgina.platformio.cache\tmp\”, line 61, in main
File “C:\Users\Georgina.platformio.cache\tmp\”, line 47, in bootstrap
File “C:\Users\Georgina.platformio.cache\tmp.piocore-installer-gy9p3msp\tmp6yie_fjy\\”, line 131, in main
File “C:\Users\Georgina.platformio.cache\tmp.piocore-installer-gy9p3msp\tmp6yie_fjy\\click\”, line 829, in call
File "C…

I just followed this link: Redirecting... but I had the same error.

I need help with steps because I’m new here. Thank you.

It is failing in the as part of the create_core_penv() function, more specifically in add_state_info(), in the code here and here. There it’s trying to execute python.exe which it should have previously downloaded.

Do you have any antivirus active that could interfere with the download and execution?

I have MC Affee and I tried disconected it but nothing happens if I tried to install it using the VS or manual installation. I have the same error.

Even I downloaded the last version of Python for W7.

I done everything… I hadn’t problems on my portable computer with W10 even having the same issue but I don’t understand why I can’t install it on W7.

Try suggestions from subprocess.CalledProcessError · Issue #221 · platformio/platformio-core-installer · GitHub, this looks like the error, since it’s failing in add_state_info().

Done using the Python directly.


Close this topic.