PlatformIO now failing on mapped network drives

Also looking for a fix for this… Mapped drive is resolving to UNC path in PIO preventing work on NAS.

I also am having this issue. More specifically when it goes to install the libraries (new computer build), it says UNC isn’t supported and then prepends the UNC project path in front of the download URL for github libraries. It ends up trying to access “\\server\share\https:\github.com\blah\file.zip”

That shouldn’t happen. What’s the exact lib_deps expression in the platformio.ini here?

Yes, I can see there was recent update to Python in November that has caused this

Early december i started getting this message.

Prior to this, it would only fail on paths that had double spaces in it (which was a bit of a folder naming convention ##__Name, etc.). That was a pain, but failing on UNC path’s is not really workable for me any more because every single file I have sits on a NAS, meaning that this issue is now a show stopper. :frowning:

The workaround they mentioned in the bit.ly link did not work for me.

Is there intention to fix this either by the python, vscode, or platformio developers? If not, is there any kind of work around like a path translator planned? Otherwise do I have to go and figure out another IDE solution; this would be a shame because I really liked it.

Thanks!

  1. What is your Windows OS version?
  2. If you ignore this warning, does the project build without any issues?
  3. I’ve just added Solution 2 to that issue. It means downgrading Python to 3.7. Does this work for you?

Hi Ivan, thanks for such a quick response and looking into it. I am reposting my deleted response as I thought I had it solved, but no, I haven’t. To answer your questions :

1: OS is Windows 10 Home version 21H1 x64 bit.
2: I though I found the issue, being another double space in the mapped folder (which doesn’t shown in the path with the network drive) All double spaces removed now, and thought this fixed it, but what really got it “working” again was opening the project folder using the UNC path with the double slashes. When I remapped it and used the network drive path again, it failed and would not build. It works with the UNC path, but the build times have blown way out and intellisense no longer works.

On side note, this double space error in the folder name created 2 sets of heavily nested folders under the project folder, and the would keep nesting until I assume it hit the character limit. It did this nesting outside of the project folder in multiple places as well. Very weird, first two subfolders in image below:

The folders keep nesting until they hit the character limit i guess, one of the paths below:
A:\100 PlatformIO projects\2020.02 HCL TTGO_COPIEDOUT\ Rob's Documents\100 PlatformIO projects\2020.02 HCL TTGO_COPIEDOUT\ Rob's Documents\100 PlatformIO projects\2020.02 HCL TTGO_COPIEDOUT\.pio\build\esp32dev

3: I tried Solution 2, but unfortunately, when i restart PlatformIO after copying over python and deleting the penv folder, it just reinstalls python first then the core.

So i suppose the problem persists. I like platformio too much to change IDE’s, so will try and keep copying back and forth between local drive and network storage where everything else is. I do hope python address this soon (and sorts out the double spaces in the path breaking things :slight_smile: )

Thanks again!

Rob

Hi all,

Has there been any progress for that issue? I’ve been using a workaround like @rwmingis for 1+ year now. I’m running PIO inside a VMWare guest and it’s the host shared drive that I cannot use to build PIO projects.
Did anyone find a trick we could use to make this work?

Any input appreciated.
Thanks.

Just tested now and that problem was fixed by a recent release:

If needed I can make a new post but the issue is not limited to python. I’m using platformio with a esp32 and I get the same annoying issue.

my s drive is mapped to 192.168.0.19\s$

I set up a project specifying s:\ … and platform IO is trying to use the UUNC path instead.

Building in release mode
Compiling .pio\build\upesy_wroom\src\main.c.o
cc1.exe: fatal error: /192.168.0.27/s$/blissbox/SOURCE_FILES/USB2LLAPI/src/main.c: No such file or directory
compilation terminated.

I really need to keep my files on my s drive, is there no way to fix this?